Error running Qiime 2 Studio on Windows WLS2 Ubuntu

Hey guys, I am trying to install q2studio on Windows subsystem for linux and when I run npm start i get the following error. Any idea to work around this problem?

This is the log file: 2020-05-18T04_28_30_220Z-debug.txt (2.9 KB)

Thanks in advance for the help!

Did you follow all of the steps listed here:

It doesn't look like you ran the first step, source activate qiime2-2020.2, if I had to guess.

If you are still running into problems, please provide us with all of the commands you have run, that will be the best way for us to be able to assist. Thanks!


1 Like

Yes did exactly the same. I am in conda qiime2 environment. I just posted the error image that’s why the command line is not visible. I will post the command line also. Please wait!

Hey there. I had some tweaking with WLS 2 display ports and was able to configure it for Virtual windows. So right now when I run I am getting following error:

Now what I have come through is that this error is related to Windows subsystem. Is there any work around for this?

Yes, it appears that way.

I don’t know - but, I don’t think so. As I understand it, WSL does not have a graphics server, so this is technically impossible (but, I could very well be wrong).

For what its worth, QIIME 2 Studio is a feature-incomplete prototype, and will possibly be discontinued in the future (in favor of another graphical interface). If you want to use Studio, my suggestion is to use the VirtualBox image, published here:

It already comes with the Studio pre-loaded.

Thank you very much for the suggestion. I will try using VB and see where it goes.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.