Error plugin Gneiss

Hello,

I run Gneiss a couple of years go using qiime2 v2019.4. I need to re-analayse something and I wanted to use the plug-in balance-taxonomy and I am getting this error
Plugin error from gneiss:
Unalignable boolean Series provided as indexer (index of the boolean Series and of the indexed object do not match

Is not working anymore? I know there are new updates but this is a manuscript already submitted and I have been asked to compare other treatment conditions and now it seems I cannot make it. I would appreciate any help. Thanks!

Welcome back, @amonm82!
I did a quick search for your error message here on the forum, and you're only the second person who's raised this issue. This sounds goofy, but have you tried re-running the command that failed? We've had trouble reproducing this error in the past, and it may be worth a shot.

If that doesn't help, try looking for a mismatch in column headers or row labels somewhere in your data. Check that you have the same number of samples in your FeatureTable and your sample metadata sheet, and maybe check if your taxonomy and balance tree feature data are different (e.g. have you subset your features along the way?)

If that doesn't get you on the right track, you're going to have to share more information with us so that we can help. As always, you should start with the full text of the command that is failing, and the full text of any error messages and error logs that result (the --verbose flag may save you digging around for log files). You'll probably also need to share your sample metadata sheet, taxonomy, feature table, and tree, so we can try to reproduce. You can send a download link in a private message to me if you don't feel comfortable sharing publicly.

Best,
CK

2 Likes

Right, that error hints at something off with the metadata - so sharing your metadata / biom table / taxonomy (or at the very least the dimensions) would be a good place to start.