Error on running silva-132-99-nb-classifier-1.qza classifier

Hi everyone

I am working on 16s Illumina data and I am trying to assign taxonomy to my data. With the green genes classifier (gg-13-8-99-515-806-nb-classifier.qza), the classification is working fine, however, the moment I use the silva-132-99-nb-classifier.qza classifier, I am getting errors, which I cannot figure out what is the problem. Any help will be appreciated.

I am using the following command in the taxonomic analysis
qiime feature-classifier classify-sklearn --i-classifier silva-132-99-nb-classifier.qza --i-reads dada2_rep_seq.qza --o-classification taxonomy.qza --p-n-jobs 4

The errors I am getting from this command
(1/2) Invalid value for “–i-classifier”: There was not enough space left on
‘/tmp’ to extract the artifact ‘silva-132-99-nb-classifier-1.qza’. (Try
setting $TMPDIR to a directory with more space, or increasing the size of
‘/tmp’)
(2/2) Invalid value for “–i-reads”: There was not enough space left on
‘/tmp’ to extract the artifact ‘dada2_rep_seq.qza’. (Try setting $TMPDIR to
a directory with more space, or increasing the size of ‘/tmp’)

When I use the exact same command with the green genes classifier it is working fine. Where am I doing something wrong here, any help?

Thank you in advance for the help

Regards
Sunette

Welcome to the forum @sunette!

Did you see the error message here? This describes the problem and solution:

So you don’t have enough space in your temp folder to load the SILVA classifier!

Greengenes is a much smaller database/classifier.

Good luck!

Dear @Nicholas_Bokulich

Thank you for the reply. I do not have much knowledge on the computers and programs, how do I get a directory with more space, can I just create a new directory? Or is it the computer which do not have enough space allocated to the qiime for this big datasets. My apologies if the questions sound plain, but I really do not have any knowledge on these type of things.

Regards
Sunette

Hi @sunette,
You can see instructions for setting a new temporary directory here:

The TMPDIR can be named whatever you want, does not need to be /data.

But if this is a personal computer I suspect the issue is not enough space on your hard drive, not TMPDIR, in which case creating a new directory will not fix… you should check out your available disc space first.

Dear @Nicholas_Bokulich

Thank you, I was using a personal computer for this, however I am currently using a computer in our lab, which is used to run sequencing results, QIIME2, etc. However, I am using the commands to check and create the directory as explained in the previous reply, but even after I did the commands to create and export the directory, I still have the same issue with no space left on device. The computer I am working on have a hardrive named New Volume (E:) with 45.8GB free of 167GB. Is the problem with the space on the hardrive of the computer or with the TMPDIR? How do I check if there is enough space on the TMPDIR should this be the problem? Below is the error I am getting after running the same command as mentioned in the first post on a different computer, which is not my personal computer.

Plugin error from feature-classifier:

[Errno 28] No space left on device

Debug info has been saved to /tmp/qiime2-q2cli-err-_gnx4n24.log

Thank you for the help in advance.

Regards
Sunette

Dear all

I have managed to fix the problem with the error on my computer. Seems like the directory I was using was perhaps just the wrong directory, I have specified the path of the tempdir to another location, where I think this solved the problem.

Regards
Sunette

1 Like

Dear sunette,
Thank you for share with us your answer. I would like to ask you gently how did you resolve this problem…because I’m having the same problem right now and my computer has 80Gb. Did you create a new directory?
I will really appreciate your reply.
Regards
Germán

Hi @g.ahumada,
Welcome to the forum! Please see the troubleshooting steps in this topic:

Good luck!

Hi @arsalane1978! It works!! Just like you said, with the same scripts. Thank you very much for your help! Since I’m new in these approaches, I would ask you why the problem can be resolved by creating a new TMP folder? Just for curiosity.
Thanks again!
German

your default TMP directory does not have enough space. Glad this helped!

2 Likes