Error: no such option: --p-min-length

Hi all,
I am new to the forum. I am working through the tutorial Training feature classifiers with q2-feature-classifier https://docs.qiime2.org/2020.2/tutorials/feature-classifier/.
Unfortunately I am running into issues because I am not using the most up-to-date version of qiime2. I managed to solve the first issue at the qiime tools import part by reverting back to the old code
–source-format HeaderlessTSVTaxonomyFormat \ which is now…
–input-format HeaderlessTSVTaxonomyFormat
However, I cannot update my version of qiime2 because I am working remotely and accessing our HPC via a vpn. I don’t have the permission to update.
I am now running into an issue at the stage of Extract reference reads part of the tutorial…
I run the following code,

but receive this error
Error: no such option: --p-min-length
I have tried to set --p-min-length to 0 so this removed this but I still run into issues.
This is the code I ran to get the above error meassge
qiime feature-classifier extract-reads
–i-sequences 85_otus.qza
–p-f-primer GTGCCAGCMGCCGCGGTAA
–p-r-primer GGACTACHVGGGTWTCTAAT
–p-trunc-len 120
–p-min-length 100
–p-max-length 400
–o-reads ref-seqs.qza

I just wondered if anyone had experienced this issue. I couldn’t find anything when I searched this time.
Thanks, Kate

Hi, @XrandallX and welcome to the forum!

Can you please share the output of qiime info? It looks like the min/max length parameters were added to extract-reads in the 2018.11 release. You are viewing the 2020.2 release version of the docs, according to the URL you shared above.

I recommend viewing the documentation which corresponds to the version of QIIME 2 you are using. From qiime info I can see that I am using QIIME 2 release 2020.8:

➜ qiime info
System versions
Python version: 3.6.11
QIIME 2 release: 2020.8
QIIME 2 version: 2020.8.0
q2cli version: 2020.8.0

You can then use the drop down menu on the left side of the QIIME 2 docs to select the correct version:

I hope that helps! Let us know if you have any more questions :smile:

1 Like

Hello,

Many thanks for your response and so sorry for wasting your time. I managed to get the person in charge of our HPC (which I am accessing remotely to update to the newest version) this has worked.
Thanks again.

2 Likes