Error: no such option: --o-output-dir

Hi there,

I'm trying to run my alpha/beta diversity analysis using core-metrics-phylogenetic command. Here is my script:

qiime diversity core-metrics-phylogenetic
--i-phylogeny diversity_analysis/rooted-tree.qza
--i-table deblur/table.qza
--p-sampling-depth 7095
--m-metadata-file deblur/metadata1CORRECTED.txt
--o-output-dir diversity_analysis/core-metrics-results-CORRECTED

It just gives me the error "Error: no such option: --o-output-dir"

I've searched the forums, docs/tutorials, the web and tried "--help" but everything seems to point to me doing this right, so I'm really stuck!

Many thanks in advance for your help.

Welcome @xchromosome!

It does look like you are doing everything correct! But I am sure there is an easy (if cryptic) solution. A couple ideas come to mind:

  1. Perhaps you are using an old version of QIIME 2? Please confirm what version you are running.
  2. If you are copying/pasting commands from the internet or (worse yet!) from MS Word or similar formatted document, special characters have a tendency to creep in… try this and let me know if you still get the error:
    • Type out the full command from scratch directly into your terminal (tab complete will help speed up this process).
    • If you like to put together a document of commands to run, use “notepad” or “texteditor” or a similar plain text editor for compiling this list, rather than Word or another word processor.

Let me know if that fixes the problem — if not we can work on a more technical solution.


Hi Nicholas,

Thanks for your help. I am running version 2019.1 on Virtual Box (version 6.0.4).

I had typed it out in the terminal directly, but I shut down my virtual machine and tried again from scratch as suggested. No luck! :cry:

I have actually encountered this problem a few times during my analysis and got around it before by using --o-output-path and, after it requested it, specifying an input path as well. But that was for different steps. I tried using --o-output-path again here but it didn’t work. (Didn’t request an input path, just gave me the “Error: no such option: --o-output-path”).


Hi! Just try
--output-dir instead of --o-output-dir :wink:


good call @timanix! I did not catch that.

1 Like

D’oh! So simple! :woman_facepalming: Thank you both!


An off-topic reply has been split into a new topic: No --output-dir option when exporting

Please keep replies on-topic in the future.