Error: No such command "aldex2"

When running the following:

qiime aldex2 aldex2
–i-table epibiont_table_filtFfiltS.qza
–m-metadata-file metadata.tsv
–p-condition subject
–output-dir aldex-test

I get the following error:

Usage: qiime [OPTIONS] COMMAND [ARGS]…

Try “qiime --help” for help.

Error: No such command “aldex2”.

Where

conda list q2-aldex2

gives me this

packages in environment at /Users/user1/miniconda3/envs/qiime2-2019.1:

Name Version Build Channel

Does this mean I haven’t installed properly Aldex2? How can I solve this?
Thanks

Hi @ecg,

Aldex2 is a plugin. Could you please send the output of the command

qiime

It should list all your plugins.

Best,
Justine

Usage: qiime [OPTIONS] COMMAND [ARGS]…

QIIME 2 command-line interface (q2cli)

To get help with QIIME 2, visit https://qiime2.org.

To enable tab completion in Bash, run the following command or add it to
your .bashrc/.bash_profile:

  source tab-qiime

To enable tab completion in ZSH, run the following commands or add them to
your .zshrc:

  autoload bashcompinit && bashcompinit && source tab-qiime

Options:
–version Show the version and exit.
–help Show this message and exit.

Commands:
info Display information about current deployment.
tools Tools for working with QIIME 2 files.
dev Utilities for developers and advanced users.
alignment Plugin for generating and manipulating alignments.
composition Plugin for compositional data analysis.
cutadapt Plugin for removing adapter sequences, primers, and
other unwanted sequence from sequence data.
dada2 Plugin for sequence quality control with DADA2.
deblur Plugin for sequence quality control with Deblur.
demux Plugin for demultiplexing & viewing sequence quality.
diversity Plugin for exploring community diversity.
emperor Plugin for ordination plotting with Emperor.
feature-classifier Plugin for taxonomic classification.
feature-table Plugin for working with sample by feature tables.
fragment-insertion Plugin for extending phylogenies.
gneiss Plugin for building compositional models.
longitudinal Plugin for paired sample and time series analyses.
metadata Plugin for working with Metadata.
phylogeny Plugin for generating and manipulating phylogenies.
quality-control Plugin for quality control of feature and sequence data.
quality-filter Plugin for PHRED-based filtering and trimming.
sample-classifier Plugin for machine learning prediction of sample
metadata.
taxa Plugin for working with feature taxonomy annotations.
vsearch Plugin for clustering and dereplicating with vsearch.

Do you need to re-start the terminal or the environment after installation?

I have installed aldex2: conda install -c dgiguere q2-aldex2
then the command is still not found…qiime aldex2 --help

Hi @ecg,

Try

qiime dev refresh-cache

after the installation, and then check your list.

PS I reclassified this as a “community support”

Best,
Justine

2 Likes

I keep having the same output/error.

I have been investigating around and could be that because I have multiple versions of R, qiime is linking aldex2 to a different version of R?

Does this make sense? I wound’t know how to check this

Hi @ecg,

In your terminal with the qiime2, can you run

R

and then in the R prompt try

library(ALDEx2)

If it gives you an error, then try running in the terminal

install.packages("BiocManager")
BiocManager::install("ALDEx2")

Then quit R in the terminal and run

qiime dev refresh-cache

The R studio or base R installed on your computer isn’t the same as the R in the qiime2 enviroment. Which is both good and bad in terms of installation.

Best,
Justine

1 Like

Hi @jwdebelius
Long story,
I had to install ALDEx2 as it wasn’t found at the beginning,

But first:

  • I also removed previous versions of R in /Library/Frameworks/R.framework and left the current one (4.0).
  • suggested alias R='/Library/Frameworks/R.framework/Versions/4.0/Resources/bin/R'
  • I have also checked and I see ALDEx2 on **/private/var/folders/cw/f68f84_d41sbtj8flvsls8mxljrs1s/T/RtmpUoKSdV/downloaded_packages

So ALDEx2 is installed and R is now 4.0.

However, when running qiime aldex2 aldex2 I keep getting the same Error: No such command "aldex2".

It is not a command when I type qiime

Hi @ecg,

Right. But, you need the ALDEX2 library inside the qiime 2 enviroment. Each qiime2 environment (conda, docker, whatever) contains a separate R environment that can’t see other R packages outside of it. So, you need to follow the instructions above where you activate your qiime 2 environment, enter R via the command line, and check the installation there.

Best,
Justine

1 Like

Hi @jwdebelius

Thanks, keeps being frustrating, I have followed yours steps above. Seems like ALDEx2 is not being installed properly as it give me a lot of errors. So I believe there is an error whithin the system, where ALDEx2 is being installed but not under the qiime environment as a plugin. As this might be an issue specific to qiime, do you know any other forums I can get help with?
Thanks,
E

Hi @ecg - you shouldn’t have to mess around with any of the system-installed frameworks (in fact, I would strongly suggest leaving them alone, breaking those can have catastrophic results on other aspects of your system).

I walked through the install guide for q2-aldex2 (https://library.qiime2.org/plugins/q2-aldex2/24/), and jotted down my notes. I used a fresh installation of QIIME 2 2020.11, nothing else installed in that env:

conda activate qiime2-2020.11
R -e 'install.packages("BiocManager", repos="http://cran.us.r-project.org")' 
R -e 'BiocManager::install("ALDEx2")' 
conda install -c dgiguere q2-aldex2 -y
qiime dev refresh-cache
qiime aldex2 --help

The last command printed out:


Usage: qiime aldex2 [OPTIONS] COMMAND [ARGS]...

  Description: Analysis Of Differential Abundance Taking Sample Variation
  Into Account

  Plugin website: https://github.com/ggloor/q2-aldex2

  Getting user support: Please post to the QIIME 2 forum for help with this
  plugin: https://forum.qiime2.org

Options:
  --version    Show the version and exit.
  --citations  Show citations and exit.
  --help       Show this message and exit.

Commands:
  aldex2               Analysis Of Differential Abundance
  effect-plot          Effect plots
  extract-differences  Extract differentially expressed features
4 Likes

@thermokarst Yes! This worked fine!
I had to uninstall qiime and re-install qiime2-2020.11 again and with a fresh environment followed your steps.

Thanks ! And thanks to @jwdebelius as well :slight_smile:

1 Like