Error message: The table does not appear to be completely represented by the phylogeny.

Hi,
I am getting the following error message ' Plugin error from diversity: The table does not appear to be completely represented by the phylogeny.'.

In the form, I found a similar error message; I tried to troubleshoot the problem based on the recommendations on other posts. Still, I am having difficulty solving the issue I have.

Based on the feature table, I chose the sampling depth of 23483 when executing qiime diversity core-metrics-phylogenetic. I believe I have enough features (65.92%) in (88.24%) samples at 23483 sampling depth.

The command I ran to generate the tree is below:
qiime fragment-insertion sepp
--i-representative-sequences ./dada2_rep_set.qza
--i-reference-database sepp-refs-gg-13-8.qza
--o-tree ./tree2.qza
--o-placements ./tree_placements.qza
--p-threads 12

The command I ran for diversity analysis is below:
qiime diversity core-metrics-phylogenetic
--i-table ./dada2_table6.qza
--i-phylogeny ./tree.qza
--m-metadata-file ./metadata.tsv
--p-sampling-depth 23483
--output-dir ./core-metrics-results

To note, the error message begins at 599 sampling depth.

Attached are the qza files for the table and the tree:
tree2.qza (2.5 MB) dada2_table6.qza (873.1 KB).

I appreciate your help!

Please read the following before posting!

Is this post about a Technical Support Question? Those include error messages observed while running QIIME 2, errors observed while installing QIIME 2, or any other "software" related problem or bug. Please do not post questions here that have to do with interpretation of results, or general discussion.

Before posting, please make sure you have the following information available, in order for us to help you in a timely manner:

  • Have you searched for the problem on the forum? It is rare that we see a new question asked, so make sure you do your homework before asking for us to commit our time to helping you.
  • Have you reviewed the QIIME 2 Forum Glossary?
  • Version of QIIME 2 you are running, and how it is installed (e.g. Virtualbox, conda, etc.)
  • What is the exact command or commands you ran? Copy and paste please.
  • What is the exact error message? If you didn't run the command with the --verbose flag, please re-run and copy-and-paste the results.

Hi @AHK,

The feature table needs to be filtered based on the tree2.qza output from fragment-insertion. I'm not sure where tree.qza comes from... in your core-metrics-phylogneetic command. Typo?

As per the fragment-insertion tutorial you need to run the following command to filter your table:

qiime fragment-insertion filter-features \
    --i-table ./dada2_table6.qza \
    --i-tree ./tree2.qza \
    --o-filtered-table ./dada2_table6_filt.qza \
    --o-removed-table ./dada2_table6_removed.qza

Then you should be able to run core-metrics-phylogenetic like so:

qiime diversity core-metrics-phylogenetic \
    --i-table ./dada2_table6_filt.qza \
    --i-phylogeny ./tree2.qza \
    --m-metadata-file ./metadata.tsv \
    --p-sampling-depth 23483 \
    --output-dir ./core-metrics-results 

Thank you Mike!
The tree.qza in core-metrics-phylogenetic command came from the output of fragment-insertion sepp command. Under Qiime2 Doc tutorials, I do not see a statement that says it is necessary to filter out the feature table. Now that you brought it to my attention, it makes sense. I ran the command to filter the table, then re-ran the core-metrics-phylogenetic command, and it's working. I appreciate your help!

1 Like