error message on import data

my file name format is
112050570_NA0008711697_4_mouth_R1_001.fastq.qz

I ran the below command to import my data
qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path casava-18-paired-end-demultiplexed --input-format CasavaOneEightSingleLanePerSampleDirFmt --output-path demux-paired-end.qza

And error message is:

There was a problem importing casava-18-paired-end-demultiplexed:

Missing one or more files for CasavaOneEightSingleLanePerSampleDirFmt: '.+_.+_L[0-9][0-9][0-9]_R[12]_001\.fastq\.gz’

Is it the format of my file name?

Hi @Dawud922 ,
Your have a single end fastq sequence but you choose a Paired End Sequences in type parameter

just change the parameter in type to SampleData[SequencesWithQuality]

If it won’t work ,u shoule give more information about how u generated the casava-18-paired-end-demultiplexed
Still I suggest using a easier import method “Fastq manifest” formats:grinning:

Sixvable

2 Likes

I have both R1 and R2 file. It is paired end.
I figured it out that it was the format of my file name. After correction I was able to import my data. Fastq manifest takes too long when you have more samples.

1 Like