Error installing qiime 2.12

Hello! I was just trying to update from qiime 2.11 to qiime 2.12 using miniconda, but I received this error message

“ERROR conda.core.link:_execute_actions(337): An error occurred while installing package ‘::bioconductor-genomeinfodbdata-1.0.0-r3.4.1_1’.
LinkError: post-link script failed for package ::bioconductor-genomeinf odbdata-1.0.0-r3.4.1_1”

I tried to get this file again from other repository in order to check if the one downloaded from the “qiime´s file” has an error…but despite of this change I receive the same error message.

does anybody know how to solve it?

Thank you so much.

Hi @Jerson_Garita - I suspect this is a transient network error. How about you clean up:

$ source deactivate
$ conda clean --all

and then try to install again.

Keep us posted! :t_rex:

Thank you so much for your advice…unfortunately, I am having the same error message.

“ERROR conda.core.link:_execute_actions(337): An error occurred while installing package ‘::bioconductor-genomeinfodbdata-1.0.0-r3.4.1_1’.
LinkError: post-link script failed for package ::bioconductor-genomeinfodbdata-1.0.0-r3.4.1_1”

I will appreciate any other idea…

thanks so much

Hmm, this one is a bit tricky — if clearing your cache didn’t help, you might be the victim of overzealous network hardware. Please see this post for some more details:

I’m sorry I don’t have a better answer for you - this gets into the realm of conda, which is something we don’t develop. If your workstation is mobile (e.g. a laptop), maybe try from a new network? Sorry, and good luck - keep us posted! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.