Error installing q2studio - rpm dependencies

Hello,

I’m trying to install q2studio on a ubuntu 18.04 machine. When I start the npm install I get those errors:

(qiime2-2021.4) 70114:~/q2studio-2021.4.0# npm install

npm ERR! code ERESOLVE

npm ERR! ERESOLVE unable to resolve dependency tree

npm ERR!

npm ERR! While resolving: q2studio@2021.4.0

npm ERR! Found: react@15.7.0

npm ERR! node_modules/react

npm ERR! react@"^15.0.1" from the root project

npm ERR!

npm ERR! Could not resolve dependency:

npm ERR! peer react@"^16.3.0" from redux-devtools-dock-monitor@1.2.0

npm ERR! node_modules/redux-devtools-dock-monitor

npm ERR! redux-devtools-dock-monitor@"^1.1.1" from the root project

npm ERR!

npm ERR! Fix the upstream dependency conflict, or retry

npm ERR! this command with --force, or --legacy-peer-deps

npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

npm ERR!

npm ERR! See /root/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:

npm ERR! /root/.npm/_logs/2021-05-04T08_56_05_788Z-debug.log

Any suggestion?

Kind regards

Cristiano Cumer

Hi, @cristianomariacumer, and welcome to the forum! :wave:

It looks like you may not be using the correct version of node. I would suggest reviewing the post here and following its advice first: Q2studio npm start error - #2 by andrewsanchez

Additionally, you should make sure that you are not overriding the node version that you should have installed with conda into your qiime 2 environment by looking at your PATH variable. You can check how your PATH variable is configured by sharing the output of this command (make sure your qiime 2 environment is activated before running these):

  • env

The output of this command would also be helpful:

  • conda list