Error installing ITSxpress: ImportError: No module named 'q2cli'

Hi!

I hope that you are all doing well.

Im having a hard time installing ITSxpress the following this tutorial.

When I ran conda install -c bioconda itsxpress

The output is:

Solving environment: done

==> WARNING: A newer version of conda exists. <==
  current version: 4.5.11
  latest version: 4.7.5

Please update conda by running

    $ conda update -n base conda

# All requested packages already installed.

Traceback (most recent call last):
  File "/home/aneth.david/.conda/envs/qiime2-2019.4/bin/qiime", line 7, in <module>
    from q2cli.__main__ import qiime
ImportError: No module named 'q2cli'

I have tried to re-install QIIME2 but when I repeat the process I get the same error.

Please help.

Regards,
Aneth.

Hi @anethdavid! Does that post represent all the commands run? For example, did you activate a conda env first? Which one?

Are you removing the conda env before reinstalling? That might be the easiest way to ensure the install is working correctly.

:qiime2:

Thank you for the response.

Yes, I activated qiime2-2019.4.

I was also running dada2 denoise paired on another screen while doing the install and uninstall part (probably shouldnt have done this), it ended with an error about a package as well. I unfortunately didn’t copy the error before restarting terminal.

No, how do I remove the conda environment before reinstalling?

1 Like

You’re welcome!

Check this post for removal instructions:

1 Like

It worked, I have ITSxpress installed!

I did:

  1. Follow instructions to remove the conda environment
  2. Reinstalled conda environment
  3. Instal qiime2
  4. Then install ITSexpress.

Thank you very much!
Aneth.

3 Likes