Error installing Amplicon Distribution sos help

Hi, I would really trully appreciate if someone could help, I'm really desperate by now :frowning:
I keep trying to install apmlicon distribution but this error keeps showing: ERROR conda.core.link:_execute(950): An error occurred while installing package 'bioconda::bioconductor-genomeinfodbdata-1.2.9-r42hdfd78af_0',
And then it stops downloading packages and keeps showing the next error at the end: ValueError: unsupported format character 'T' (0x54) at index 2172

I really don't know how to fix this, I've tried a lot of things like usimg the comand conda clear --all, or even changing my internet connection, but it keeps failing






1 Like

It looks that you already have an environment called qiime2-amplicon-2024.2 (that's why you get the CondaValueError in your first command, because it already exists). Can you do conda activate qiime2-amplicon-2024.2 and share the output with us?

In your next command you download again the YAML file containing the instructions for creating the environment. You don't need to do that every time you attemp to create an environment. If you look closely, you downloaded the file qiime2-amplicon-2024.2-py38-linux-conda.yml.5 (note the final 5 in the filename). That means you downloaded the same YAML file 6 times, but if you look at your conda env create commands you always use the YAML file you downloaded the first time (look at the filename, qiime2-amplicon-2024.2-py38-linux-conda.yml, without trailing numbers). This is a little bit off-topic but in Bioinformatics it is important to understand every thing you do :nerd_face:

Regarding the next command (the one that throws the error), it doesn't throw the CondaValueError becuse you slightly changed the environment name adding an extra letter 'o' in qiime2-amplicoon-2024.2 (I assume this is on purpose). Regarding the error itself, I suppose you already saw it but that same error is addressed here:

They suggest using conda clean --all. Could you please share also the output of that command? I know you said that you already tried but the command you said has a typo (clear instead of clean).

Best wishes :chipmunk:

2 Likes