Error Installing 2019.4 on MacOS

Hello, I’m having some trouble installing the newest version of Q2. I’m not the most knowledgable about conda, so apologies if this is something silly.

Essentially everything seems to install OK, but I get the error message:

Preparing transaction: done

Verifying transaction: done

Executing transaction: failed

ERROR conda.core.link:_execute(502): An error occurred while installing package ‘conda-forge::atomicwrites-1.3.0-py_0’.

FileNotFoundError(2, “No such file or directory: ‘//anaconda/envs/qiime2-2019.4/bin/python3.6’”)

Attempting to roll back.

Rolling back transaction: done

FileNotFoundError(2, “No such file or directory: ‘//anaconda/envs/qiime2-2019.4/bin/python3.6’”)

I have tried running the following:
conda update conda
conda clean -y --all

A folder with the new 2019.4 conda environment is created during the install process, but I cannot delete it through conda env --remove (I have to manually delete the folder)

Any ideas for how I can fix this?

Here is my conda information if that helps:

 active environment : None
        shell level : 0
   user config file : /Users/avrbanac/.condarc

populated config files : /Users/avrbanac/.condarc
conda version : 4.5.11
conda-build version : 1.21.3
python version : 3.5.2.final.0
base environment : //anaconda (writable)
channel URLs : https://conda.anaconda.org/bioconda/osx-64
https://conda.anaconda.org/bioconda/noarch
https://conda.anaconda.org/conda-forge/osx-64
https://conda.anaconda.org/conda-forge/noarch
https://repo.anaconda.com/pkgs/main/osx-64
https://repo.anaconda.com/pkgs/main/noarch
https://repo.anaconda.com/pkgs/free/osx-64
https://repo.anaconda.com/pkgs/free/noarch
https://repo.anaconda.com/pkgs/r/osx-64
https://repo.anaconda.com/pkgs/r/noarch
https://repo.anaconda.com/pkgs/pro/osx-64
https://repo.anaconda.com/pkgs/pro/noarch
package cache : //anaconda/pkgs
/Users/avrbanac/.conda/pkgs
envs directories : //anaconda/envs
/Users/avrbanac/.conda/envs
platform : osx-64
user-agent : conda/4.5.11 requests/2.13.0 CPython/3.5.2 Darwin/15.5.0 OSX/10.11.5
UID:GID : 501:20
netrc file : None
offline mode : False

It’s might be conda version’s issue. I also suffered with the same problem when stalling qiime2-2019.4. Update conda version should be worked at this situation.

3 Likes

Thanks! Yeah annoyingly I couldn’t get my conda version to update from 4.5.11 (after trying endless methods…). I ended up doing a fresh install of miniconda with the newest conda version and it works

5 Likes