Error in qiime emperor biplot

Hi Everyone,

I’m working in qiime2-2021.11.0 and I have this error message when i ran this:

qiime emperor biplot
--i-biplot world_pcoa_biplot_2.qza
--m-sample-metadata-file world-boiling-metadata2.tsv
--m-feature-metadata-file world-cutadapt_taxonomy.qza
--o-visualization world_pcoa_biplot_2.qzv

I have this error message

Plugin error from emperor:

None of the feature identifiers match between the metadata and the coordinates. Verify that you are using metadata and coordinates corresponding to the same dataset.

Debug info has been saved to /tmp/qiime2-q2cli-err-z4tzlmuw.log

The code worked for me when I didn't collapse my table. However, when I collapsed to the phylum level (level 2) I got the error message. There were 4 samples that were removed in the rarefaction but as I said that didn't cause problems before. I upload the qza files in case it works for you. Thank you very much in advance.
world_pcoa_biplot_2.qza (339.1 KB)
world-boiling-metadata2.tsv (2.6 KB)
world-boiling-metadata.tsv (2.6 KB)
world-cutadapt_taxonomy.qzv (6.3 MB)

@fellora, when you collapse the table, it renames the features with a taxonomically derived name. You should be able to leave out the feature-metadata and it should work just fine :slightly_smiling_face:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.