Error in importing data to qiime2

Hi,

I am trying to import the data to qiime2 in the form of Casava 1.8 paired-end demultiplexed fastq. I am using these commands:
qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path casava-18-paired-end-demultiplexed
--input-format CasavaOneEightSingleLanePerSampleDirFmt
--output-path demux-paired-end.qza
using these fastQ data:
image

But I received this error:
Invalid value for '--input-path': Path 'casava-18-paired-end-
demultiplexed' is not readable.

Does anyone know how to troubleshoot this? Thanks so much

Hello @phamhuong92, it sounds like you don't have permission to access that directory. That looks like Windows, so you're using the Linux Subsystem right? If those files are on the Linux portion of your file system, then I would imagine you can use Linux shell commands to set permissions. You would do that by running the command chmod 777 *directory name* from a terminal in the subsystem. That will set blanket access permissions for that directory which should work for your purposes. You may need to sudo the command. If that doesn't work, then you probably need to set the permissions in Windows not in Linux, and unfortunately I'm not sure how to do that.

Hello @Oddant1 thank you so much for helping me, Yes Im using Linux Subsystem, after I ran command chmod 777 and imported data i received other error: [Errno 13] Permission denied: 'casava-18-paired-end-demultiplexed/02BE010011_S3_L001_R1_001.fastq.gz'

That sounds like the files in the directory also don't have the correct permissions. The easiest way to fix this would be to run the same chmod 777 command as before but with a -R flag this time, so it would look like chmod -R 777 *directory name* that will change the permissions on the directory (which seems to have worked already) and all the files inside of it (which seems to be the current issue).

@Oddant1 I appreciate your help so much. I'll try it to see if it works