Error in importing data sets

Hello all
I tried to dereplicate my dataset using
qiime vsearch dereplicate-sequences
however I got an error
(1/1) Invalid value for ‘–i-sequences’: Expected an artifact of at least
type SampleData[Sequences] | SampleData[SequencesWithQuality] |
SampleData[JoinedSequencesWithQuality]. An artifact of type
FeatureData[Sequence] was provided.
I then tried to import the data as Sample Data [Sequences], but i got this error
qiime tools import --input-path Rhizosphere.fasta --output-path Rhizosphere.fasta.qza --type ‘SampleData[Sequences]’
There was a problem importing Rhizosphere.fasta:

Rhizosphere.fasta is not a(n) QIIME1DemuxFormat file.
How to fix this error.
thanks in Advance.

Can you show us the first ~10 lines of “Rhizosphere.fasta”?

Hi thermokarst
Here they are

M02605:11:000000000-B9578:1:1102:23610:1833 1:N:0:ATTACTCG+TATAGCCT
GATTCCTACGGGCGGCTGCAGTAGGGAATATTGCATAATGGGCGCAAGCCTGATGCAGCA
ACGCCGCGTGTGCGATGAAGGCCTTCGGGTTGTAAAGCACTTTTGATCGGGAAGAGGAAG
GACGGTACCGGTCGAAGAAGCCTCGGCTAACTACGTGCCAGCAGCCGCGGTAAAACGTAG
GAGGCGAGCGTTATCCGGATTTACTGGGTGTAAAGCGCGTGCAGGCGGTTGGCTAAGTTG
GGTGTGAAAGCTCCTGGCTCAACTGGGAGAGGTCGCTCAAGACTGGCCGACTGGAGAGCA
GTAAGGGAAGGTGGAATTCCGGGTGTAGTGGTGAAATGCGTAGATATCCGGAGGAACACC
AGTGGCGAAAGCGGCCTTCTGGACTGCATCTGACGCTCAGACGCGAAAGCTAGGGGAGCA
AACGGGATTAGATACTCGAGTAGTC
M02605:11:000000000-B9578:1:1102:12939:1887 1:N:0:ATTACTCG+TATAGCCT

Thanks @divyaprince321 - this does not appear to be the right format for importing as a QIIME1DemuxFormat file, you can see the spec for the expected file layout, here:

http://qiime.org/documentation/file_formats.html#post-split-libraries-fasta-file-overview

I'm not aware of any method to work with these data in QIIME 2 right now - you appear to have barcode sequences in the FASTA header line (and they appear to be dual-index barcodes, as well) - we don't have any tools that are capable of demultiplexing sequences with barcodes in the header. If you can find a way to turn this into a QIIME1DemuxFormat, then you can import it and dereplicate the reads, but until then, I don't have any other ideas for you.

:qiime2:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.