Error importing manifest file

Hi there!

I am very new to bioinformatics and am analyzing a dietary dataset. I’m running QIIME 2 version 2020.11 through WSL and Ubuntu. I have run into some trouble while attempting to import my data. I ran into an error while trying to import my dating using the Casava 1.8 format, so decided to try the manifest format with 2 of my samples after following the manifest import tutorial.

Code I ran to import:
qiime tools import \

–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path pe-33-manifest.tsv
–output-path paired-end-demux.qza
–input-format PairedEndFastqManifestPhred33V2

Error that I’m getting:
There was a problem importing pe-33-manifest.tsv:

pe-33-manifest.tsv is not a(n) PairedEndFastqManifestPhred33V2 file:

Filepath on line 1 and column “forward-absolute-filepath” could not be found ($PWD/pe-33/842026339_S44_L001_R1_001.fastq.gz) for sample “842026339”.

Here are the 2 samples I am attempting to import:
fastq_files

My manifest.tsv file:

Any help is much appreciated, thank you!

Hello @Newt!

Welcome! :wave:

Thanks for the detailed report, this is really helpful. So let’s start with breaking down this part of the error message:

What QIIME 2 is telling you here is that the is no file present at the path $PWD/pe-33/842026339_S44_L001_R1_001.fastq.gz. This could be for a few reasons:

  • what is the current directory you are in when you run the command? perhaps you need to move somewhere else
  • you might have a typo in the name
  • switching to absolute filepaths might be easier to reason about

If the tips above don’t get you moving forward, please share with us some more detailed information about your directory layout for these files.

:qiime2:

2 Likes

Thank you for your quick response! I was able to figure it out, I had put the wrong directory path in the file name. :sweat_smile:

1 Like