Error Importing into Qiime with paired end demultiplex reads

Greeting Qiime hive mind,

I'm having an issue importing demultiplex reads using the fastq-manifest.

System: Ubuntu 20.04.6 LTS
Qiime Version: q2cli version 2023.5.1
Installed via conda

This is the command I was running

qiime tools import \
--type 'SampleData[SequencesWithQuality]' \
--input-path LS23-4703_pe-33-mainfest.txt \
--output-path paired-end-demux.qza \
--input-format PairedEndFastqManifestPhred33V2

this is the current format for the manifest file.

sample-id	absolute-filepath	direction
LS23-5403-1	$PWD/data/LS23-5403-1-16s_S1_L001_R1_001.fastq.gz	forward
LS23-5403-1	$PWD/data/LS23-5403-1-16s_S1_L001_R2_001.fastq.gz	reverse

I also tried with the forward-absolute-filepath and reverse-absolute-filepath format and received the same error.

error message:

Traceback (most recent call last):
  File "/home/rnd/miniconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/q2cli/builtin/", line 266, in import_data
    artifact = qiime2.sdk.Artifact.import_data(type, input_path,
  File "/home/rnd/miniconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/qiime2/sdk/", line 327, in import_data
    return cls._from_view(type_, view, view_type, provenance_capture,
  File "/home/rnd/miniconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/qiime2/sdk/", line 353, in _from_view
    transformation = from_type.make_transformation(to_type,
  File "/home/rnd/miniconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/qiime2/core/", line 58, in make_transformation
    raise Exception("No transformation from %r to %r" %
Exception: No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

An unexpected error has occurred:

  No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

See above for debug info.

I did try to run this command with the --verbose flag but received an error saying no such option: --verbose

I'm not sure if the error is becasue it wants to make my paired end data single end and can't or (more likely) I choose the wrong option. I have tried using the more abstract FastqGZFormat as well and get the same error.

If anyone can point me in a direction I would appreciate it.

Thank you,

Hello @skbrimer,

I believe the --type you want is 'SampleData[PairedEndSequencesWithQuality]'.

@colinvwood , Yes! Thank you that was the main issue, I knew it was a user error. I also had to go back and reformat the manifest file to the forward-absolute-filepath and reverse-absolute-filepath

Thank you again!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.