Error importing data- Moving Picture Tutorial

I am new to QIIME and I have installed QIIME2 using WSL. I have tried every possible way to import the files in QIIME and continue to get this error(please see below) while doing “Moving Picture Tutorial”. Can someone please tell me how to resolve this issue?

$ qiime tools import \

–type EMPSingleEndSequences
–input-path emp-single-end-sequences
–output-path emp-single-end-sequences.qza
Traceback (most recent call last):
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/q2cli/builtin/tools.py”, line 158, in import_data
view_type=input_format)
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/result.py”, line 241, in import_data
validate_level=‘max’)
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/result.py”, line 273, in _from_view
provenance_capture=provenance_capture)
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/core/archive/archiver.py”, line 316, in from_data
Format.write(rec, type, format, data_initializer, provenance_capture)
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/core/archive/format/v5.py”, line 21, in write
provenance_capture)
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/core/archive/format/v1.py”, line 26, in write
prov_dir, [root / cls.METADATA_FILE, archive_record.version_fp])
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/core/archive/provenance.py”, line 320, in finalize
self.path.rename(final_path)
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/pathlib.py”, line 1309, in rename
self._accessor.rename(self, target)
File “/home/meenu/anaconda3/envs/qiime2-2020.11/lib/python3.6/pathlib.py”, line 393, in wrapped
return strfunc(str(pathobjA), str(pathobjB), *args)
PermissionError: [Errno 13] Permission denied: ‘/tmp/qiime2-provenance-syyx2l0b’ -> ‘/tmp/qiime2-archive-4goljwjr/6cb3be50-ae0f-4d7a-a5c2-505b26655221/provenance’

An unexpected error has occurred:

[Errno 13] Permission denied: ‘/tmp/qiime2-provenance-syyx2l0b’ -> ‘/tmp/qiime2-archive-4goljwjr/6cb3be50-ae0f-4d7a-a5c2-505b26655221/provenance’

See above for debug info.

Welcome to the forum, @Meenu!
I don’t have any direct experience with WSL, but other users have solved similar issues by running as Admin. Do you have the permissions you need to try that on your system?

Let us know how it goes!
Best,
Chris :elephant:

1 Like

I tried running as an administrator, but I was getting the same error (as mentioned above) while importing the files. Any help would be appreciated.

Thanks!

@Meenu , how did you go about “running as an administrator?” I just want to make sure we’re on the same page about what the means. This topic is slightly complicated and will rely on the specifics of your machine. I would suggest Googling “wsl permission denied,” to begin investigating what the issue is in your particular situation. I think it’s safe to say at this point that this isn’t due to a QIIME 2 bug, per se, rather the quirks of WSL. The reason I mention that is to say that there’s not much we can do until we know more about why you’re running into the error.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.