Error importing casava demultiplexed files

Hello,

I have a quick question, I have been trying to import demultiplexed files (see code below) and I keep getting an error. I have previously uploaded files for my two other libraries and had not encountered this problem. I found this link where it says that my naming convention might be wrong, but after changing the subtle things that did not match in four of the files, I still get the same error.

Can you please let me know what I am doing wrong.

Code
*qiime tools import *
*--type 'SampleData[PairedEndSequencesWithQuality]' *
*--input-path casava-18-paired-end-demultiplexed *
*--input-format CasavaOneEightSingleLanePerSampleDirFmt *
--output-path Demux/Bacteria-demux-paired.qza

Error code: There was a problem importing casava-18-paired-end-demultiplexed:

Missing one or more files for CasavaOneEightSingleLanePerSampleDirFmt: '.+_.+_L[0-9][0-9][0-9]_R[12]_001\.fastq\.gz'

Screen Shot 2020-08-28 at 4.26.58 PM

Hi @fabipc!

You’re missing the lane number in your file names. It might be faster and easier at this point to use a manifest format, instead:

https://docs.qiime2.org/2020.8/tutorials/importing/#fastq-manifest-formats

Hi @thermokarst

Again, thank you for your quick response (you have no idea how much I boast about the qiime2 forum).

Thanks again, I will try using the manifest format :slight_smile:

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.