Error .git/hooks/post-update.sample with importing via the casava 1.8 paired-end demultiplexed route

import

(Lotte Geerlings) #1

Hello everyone,

I am rather new at Qiime and I am trying to import my data with the Casava 1.8 paired-end demultiplexed fastq.tutorial.

My data looks like this:
ILC-oral-1_29236_GGAGCTACAAGGAGTA_L001_R1_001_000000000-BLW63.filt.fastq.gz

and therefore I changed it to fit the casava formula to:

1_GGAGCTACAAGGAGTA_L001_R1_001.fastq.gz

And now when I run

qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path oral_seq/oral_casava_import
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path demux-paired-end.qza

However, now I get the error message:

“There was a problem with importing oral_seq/oral_casava_import/:
Unrecognized file (oral_seq/oral_casava_import/.git/hooks/post-update.sample) for CasavaOneEightSingleLanePerSampleDirFmt.”

Your help would be greatly appreciated!

Thank you in advance,
Lotte


(Justine) #2

Hi @Lotte,

I’d recommend trying the sample manifest format. It’s a little bit more flexible than trying to coerce your data into the casava format.

Best,
Justine


(Nicholas Bokulich) #3

Hi @Lotte,
@jwdebelius is correct, the manifest format is easier to work with… your files can be named anything and stored in all different places. So you could have saved yourself the trouble of renaming your files!

That said, I just want to address this problem:

The casava1.8 import format expects that only casava 1.8 fastq.gz files will be present in the input directory path (oral_seq/oral_casava_import/). Nothing else should be there. You have a hidden directory (.git) in there that contains at least one file (.git/hooks/post-update.sample), so QIIME 2 is getting upset! Either remove that directory and all other non-fastq.gz filepaths from your input directory path, or use the manifest format.

Good luck!


(Lotte Geerlings) #4

Thank you Justine! That worked!