Error during demultiplexing using 2019 versions

I am re-analyzing a dataset that I’ve previously, and successfully, analyzed using a 2018 version of qiime2, this time using versions 2019.4, and 2019.10. Here is my command:

qiime demux emp-paired
–m-barcodes-file sample_metadata.txt
–m-barcodes-column BarcodeSequence
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux.qza
–o-error-correction-details demux-details.qza
–verbose

This time, I keep getting the following error:

ValueError: No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options).

These are golay barcodes that should be in the forward primer with no need to do the reverse complement. Does anyone have any idea of why this isn’t working this time? Are there any changes that occurred between 2018 and 2019 that I am missing?

Best,

Linnea

Yep! We added automatic Golay barcode error correction earlier this year. In order for EC to work you have to:

a) ensure your barcode sequences are in 5’-3’ orientation
b) ensure your barcode mapping is in 5’-3’ orientation

There are two flags to control that behavior, rev-comp-barcodes and rev-comp-mapping-barcodes, respectively. You can also completely disable EC by using the golay-error-correction flag.

Are the barcode sequences in the same orientation as the barcode mapping? It sounds like if they are, then your barcode sequences themselves are in the wrong orientation, and you will need to RC both barcode sequences and the barcode mapping.

Thank you! Doing RC on both barcode sequences and barcode mapping solved this issue.

1 Like