[Error] bash: conda: command not found...

Dear developers,

I want to ask about how to create an env for qiime2.
I tried to create an env for qiime2 on Putty, but I failed to do that.

Here are the commands I used.

curl -O https://repo.anaconda.com/archive/Anaconda3-2022.05-Linux-x86_64.sh
bash Anaconda3-2022.05-Linux-x86_64.sh
export PATH="~/home/username/Anaconda3-2022.05-Linux-x86_64/bin:$PATH"
. ~/.bashrc
conda env create -n qiime2-2022.8 --file qiime2-2022.8-py38-linux-conda.yml

Then, Putty said that
bash: conda: command not found...

I googled "bash: conda: command not found..." and also checked this problem in Qiime2 forum, but couldn't find how to this problem.
I know this is not your fault, but I'm not familiar with Linux commands, and I need your help.

I'd be glad if you had a solution to this problem.

Sincerely

Good afternoon @knbostaurus,

Welcome to the forums! :qiime2:

After installing Anaconda / conda, you have to restart your bash session so the new conda setup is recognized. Did you try that?

(The easy way to do that is close to putty, then open putty again and reconnect.)

If conda is installed, you will see the (base) conda environment listed once you reconnect:
Screen Shot 2022-11-14 at 12.20.37 PM

P.S. If that does not fix it, let us know and we can keep troubleshooting!

Hello Colin,

I didn't restart PuTTy.
And when I restarted it, I could see the base conda environment and conda commands worked!

I really appreciate your help.

Sincerely

1 Like