Errno 28 running feature-classifier Silva - message Killed: 9

Hi all –
Thanks in advance for all the help on the forum. I am trying to run feature-classifier classify-sklearn on my 16S samples using Silva. I am using Mac Mojave with Qiime installed through conda and running on terminal. First, I ran

`/qiime feature-classifier classify-sklearn \
> --i-classifier silva-132-99-515-806-nb-classifier.qza \
> --i-reads repseqs-deblur-16S.qza \
> --o-classification taxonomy-16S.qza`

and got [Errno 28] No space left on device

Then I read through the forums and checked df -h

`df -h
Filesystem      Size   Used  Avail Capacity iused               ifree %iused  Mounted on
/dev/disk1s1   113Gi   97Gi   13Gi    88% 1784252 9223372036852991555    0%   /
devfs          190Ki  190Ki    0Bi   100%     658                   0  100%   /dev
/dev/disk1s4   113Gi  2.0Gi   13Gi    14%       2 9223372036854775805    0%   /private/var/vm
map -hosts       0Bi    0Bi    0Bi   100%       0                   0  100%   /net
map auto_home    0Bi    0Bi    0Bi   100%       0                   0  100%   /home
/dev/disk2s2   465Gi  312Gi  154Gi    67% 6172132          4288795147    0%   /Volumes/NRG`

So then I ran
export TMPDIR='/Volumes/NRG'
and confirmed with echo $TMPDIR

Then I re-ran my feature-classifier and this time it ran for longer and then I got the message Killed: 9 nothing else and no taxonomy file exported.
I couldn’t figure out from the forums what to do from this point to try to work around this. I’ve successfully ran this command before on 16S samples but with a smaller number of files so I wonder if that’s the reason why this isn’t working now.

Thank you!

Welcome to the forum @natasharg!

This is a memory error — see here for troubleshooting details:

Good luck!

1 Like

I freed up space on my hard drive so it has 335GB and the computer has 27GB free but I ran it again last night and still got the same message Killed: 9 after my terminal said disk space was critically low. Would the reads-per-batch parameter have anything to do with this problem?

Yep, this is a memory error so the issue is RAM, not hard drive space.

Yes! Give that a try and this should work.


I ran the command again on the new TMPDIR but with --p-reads-per-batch 1000 as well and got the taxonomy file after around 5 hours! Thank you!