Emperor: custom axis and numeric data error

Good afternoon,
I am using Qiime 2 foe microbial data analysis, and I suffered from a problem when I tried the Alpha and beta diversity analysis. When we used the Emperor tool to explore principal coordinates (PCoA) plots in the context of sample metadata followed those commands: qiime emperor plot --i-pcoa core-metrics-results/bray_curtis_pcoa_results.qza --m-metadata-file junfei_overall_mapping.tsv --p-custom-axis period --o-visualization core-metrics-results/bray-curtis-emperor-Period.qzv, it came out a problem like: Plugin error from emperor:
All values in a custom axis must be numeric, this summary shows the invalid values and the number of times they were found in column ‘Period’: NaN 4
We checked the core-metrics-results2/bray_curtis_emperor.qzv, and saw four samples could not be recognized which showed “nan”. But all of the sample ID and period number have no problem, what do you think the possible problem is? Really appreciate if you can fix the problem for me! thank you so much!

1 Like

Good morning,

Thanks for posting your full command and error! I think the problem is within your metadata file.
'Period’: NaN 4
This tells me that you have a column called Period and it includes NaN or “not a number” entries. Maybe there are come blank entries in this column?

Let me know what you find in the Period column, and I can help you fix it to avoid this error,
Colin

1 Like

Hi Colin,

Thank you so much for the response! I have checked my mapping file many times, but could not find anything wrong. I have uploaded my metadata file, could you help me to fix the error please? Thank you!

Junfei

junfei_overall_mapping_above6072_corrected_period.tsv (78.6 KB)

Hi @junfei_guo! I can’t find any missing or non-numeric values in the Period column of the metadata file. I noticed that the metadata file’s name differs from what you used in the original command (junfei_overall_mapping.tsv vs junfei_overall_mapping_above6072_corrected_period.tsv). Also, in your command you used a column called period, while in the metadata file you attached, the column name is Period (notice the difference in casing). Can you try rerunning the command using the metadata file you attached, and let us know if you still receive an error?

If that doesn’t work, please post the exact command you’re running and full error message, and provide the exact metadata file and bray_curtis_pcoa_results.qza file as attachments so that we can try to reproduce the error locally. Please also let us know what version of QIIME 2 you’re using (run qiime info to get that info).Thanks!

Hi Jai,

Thanks for the quick response. Because the bray_curtis_pcoa_results.qza file is too big, so I replied by email. Thank you so much!

Junfei

@junfei_guo, I didn’t receive an email or direct message on the forum. Can you try resending it? Please also be sure to provide the other details I requested in my last post. Thanks!

Thanks for the data and details @junfei_guo, I received them by email. I was able to reproduce the issue with QIIME 2 2017.12, and I’m not sure why Emperor isn’t happy with your metadata (the Period column looks numeric without any missing values). I tried out the latest QIIME 2 release (2018.2), and the command succeeded (with reasonable looking Emperor plots). Can you try updating to the latest release (2018.2) and rerun the command? Thanks!

1 Like

Dear Jai,

I tried the latest version and it works! Really appreciate your suggestion, thank you so much!

Junfei

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.