Duplicate samples in feature tables during merge

Hey thank you for the help. I have a perhaps a closely associated question:

I have 7 MiSeq runs, they have been DADA’d and denoised:

qiime feature-table merge \

–i-tables ~/QIIME2_4_DADA2/180209_MSQ72/table-1.qza
–i-tables ~/QIIME2_4_DADA2/180215_MSQ73/table-2.qza
–i-tables ~/QIIME2_4_DADA2/180216_MSQ74/table-3.qza
–i-tables ~/QIIME2_4_DADA2/180417_MSQ77/table-4.qza
–i-tables ~/QIIME2_4_DADA2/180420_MSQ78/table-5.qza
–i-tables ~/QIIME2_4_DADA2/180509_MSQ79/table-6.qza
–i-tables ~/QIIME2_4_DADA2/180518_MSQ80/table-7.qza
–o-merged-table ~e/QIIME2_5_merge/data/merge.table.qza

I receive an error:

Plugin error from feature-table:

Same samples are present in some of the provided tables: Blank

Debug info has been saved to /var/folders/82/86pyg4s12_vb2mzdf8yknlrh0000gn/T/qiime2-q2cli-err-gci2w6y6.log

I assume it is because samples in the MiSeq runs have the same title. Which will need to be addressed. How should I go about this? Or when/where should each of these samples be renamed?

Interestingly, I was able to merge the seq.qza files with success:

qiime feature-table merge-seqs \

–i-data ~/QIIME2_4_DADA2/180209_MSQ72/rep-seqs.qza
–i-data ~/QIIME2_4_DADA2/180215_MSQ73/rep-seqs.qza
–i-data ~/QIIME2_4_DADA2/180216_MSQ74/rep-seqs.qza
–i-data ~/QIIME2_4_DADA2/180417_MSQ77/rep-seqs.qza
–i-data ~/QIIME2_4_DADA2/180420_MSQ78/rep-seqs.qza
–i-data ~/QIIME2_4_DADA2/180509_MSQ79/rep-seqs.qza
–i-data /~/QIIME2_4_DADA2/180518_MSQ80/rep-seqs.qza
–o-merged-data ~/QIIME2_5_merge/data/rep-seqs.qza
Saved FeatureData[Sequence] to: ~/QIIME2_5_merge/data/rep-seqs.qza

Thank you. Ben

EDIT:

It looks like the step I need to redo is at the:
'qiime demux emp-paired ’ Step, we run blank wells on all our runs to see what the background microbiome may look like and this also helps us control for background intrusion. I may need to re-run most of this - however it looks like there are only 3 blank samples that have the same names. Could I just go head and force the merge despite this? It will take me a couple of days to redo the demux–>dada/denoise step.

You can rename samples in a feature table using this trick. No need to re-do anything.

Another option would be to filter out the Blank samples.

Because that file just contains feature IDs and sequences, not sample IDs (which cause the issue when merging tables).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.