DOCKER and conda (minor) issues

Hi Qiime2 developers

Thanks for all your hard work and support!

I have a workaround for my (specific) case, but wanted to point these out to help anyone in similar situation and/or so developers can suggest a fix in the next version of qiime2. Please move this to the “Developer discussion” or “Ideas and suggestions” as you feel appropriate.

Installation of 2018.8 via conda worked like a charm. However, for some reason at the DADA2 step my machine (part of a SGE cluster) loaded some older versions of S4vectors, even though I can see in my conda env that there is the correct version of S4vectors. I tried reinstalling conda, editing paths (prefixing conda path to my libs path) but nothing seemed to fix it.

I downloaded docker image of 2018.8. However, docker had issues writing to my output directory. Creating a all read/write/exec dir and running docker_qiime in that dir seems to work (generated the feature table with dada2) and creates the files as “nobody”. At the end of analysis I plan to change files/dir permissions and ownership.

Also, with docker I think we do not have all plugins available (e.g. q2-fragment-insertion) that are available with conda, so I use the conda here to run those specific plugins (analysis).


1 Like

Hey there @Richard_Rodrigues1!

Did you happen to specify the user that docker should execute as? For example:

docker run -it -u $(id -u):$(id -g) -v $(pwd):/data qiime2/core:2018.8 qiime \
  metadata tabulate \
    --m-input-file stats-dada2.qza \
    --o-visualization stats-dada2.qzv

The part with -u $(id -u):$(id -g) will pass your current user and primary group into docker, which in turn will use that in the QIIME 2 docker image to execute (and write files) as.

The beauty of docker is that you can create your own Dockerfile which inherits from our base docker image, then you can install whatever you might want in there. There are a few examples of that floating around on this forum, and tons on Docker's official documentation.

:qiime2: :t_rex:

Cool, will try that!



1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.