Diversity Alpha Rarefaction no attribute 'type'

I am running QIIME 2018.11 which I installed with conda, and I am getting the following error message after running qiime diversity alpha-rarefaction:

Plugin error from diversity:  'set' object has no attribute 'type'

When I dig further into the log, this is what the error seems to be:

Traceback (most recent call last):
  File "/home/robg/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/q2cli/commands.py", line 274, in __call__
    results = action(**arguments)
  File "<decorator-gen-407>", line 2, in alpha_rarefaction
  File "/home/robg/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/action.py", line 199, in bound_callable
  File "/home/robg/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/core/type/signature.py", line 301, in check_types
    name, kwargs[name].type, spec.qiime_type))
AttributeError: 'set' object has no attribute 'type'

I have tried to search what this error could be attributed to, but I am struggling to find a cause. I would greatly appreciate if anyone can provide guidance on how to solve this.

Can you please provide the complete command you ran? Thanks!

Hi @thermokarst. Thank you for your reply. The command I ran is below. I tried to run this with the tourmaline Snakemake pipeline, and also just running it manually in the command line:

qiime diversity alpha-rarefaction --i-table 02-denoised/dada2-pe/table.qza \
--i-phylogeny 03-repseqs/dada2-pe/rooted_tree.qza \ 
--p-max-depth 10000 \ 
--p-metrics faith_pd \ 
--p-metrics shannon \ 
--p-metrics observed_otus \ 
--p-metrics evenness \ 
--m-metadata-file 00-data/sample-metadata.tsv \
--o-visualization 04-diversity/dada2-pe/alpha_rarefaction.qzv

This is an older, unsupported version of QIIME 2 - any chance you can upgrade to 2019.4?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.