Demux summary error

Hello,

I have a quick question: I am trying to run the qiime demux summarize and I keep getting the following error, based on the following code:
*qiime demux summarize *
*–i-data Fungal-demux-paired-end.qza *
–o-visualization Fungal-demux-summary.qzv

Plugin error from demux:
Compressed file ended before the end-of-stream marker was reached
Debug info has been saved to /tmp/qiime2-q2cli-err-6mwhwk0v.log

This is the first time I get this error, and I have checked the forum to see how to address the issue but it suggest the fastq.gz files could be corrupt. How can I verify if that is the case and or is there anything else I should do?

It’s also possible that one of the qiime 2 artifacts (qza and qzv) could be corrupt. Try using qiime tools extract to extract both these files, and see if that command is able to run or if that causes issues as well.

Colin

P.S. There is probably more clues in the .log file. What did the log file say?

Good call @colinbrislawn, I agree, it is likely that one of the fastq.gz files are corrupt. Instead of extracting the data though, I think @fabipc should run:

qiime tools validate Fungal-demux-paired-end.qza

This will perform detailed validation of the demuxed seqs.

:t_rex:

1 Like

The command ran on the qza file, I cannot run it on the qzv files because the code did not work, and so no file was generated.

When I run the “qiime tools extract” on the qza file, it returns my fastaq.gza files.

When I ran the “qiime tools validate” on the qza file, it returns the following error:
An unexpected error has occurred while attempting to validate result Qiime/Fungal-demux-paired-end.qza:

  • Compressed file ended before the end-of-stream marker was reached*

Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/q2cli/builtin/tools.py”, line 404, in validate
result.validate(level)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/sdk/result.py”, line 319, in validate
self.format.validate(self.view(self.format), level)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/plugin/model/directory_format.py”, line 171, in validate
getattr(self, field)._validate_members(collected_paths, level)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/plugin/model/directory_format.py”, line 101, in _validate_members
self.format(path, mode=‘r’).validate(level)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/plugin/model/file_format.py”, line 24, in validate
self.validate(level)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/q2_types/per_sample_sequences/_format.py”, line 279, in validate
self._check_n_records(record_count_map[level])
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/q2_types/per_sample_sequences/_format.py”, line 239, in check_n_records
for i, record in file
:
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/gzip.py”, line 289, in read1
return self._buffer.read1(size)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/_compression.py”, line 68, in readinto
data = self.read(len(byte_view))
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/gzip.py”, line 482, in read
raise EOFError("Compressed file ended before the "
EOFError: Compressed file ended before the end-of-stream marker was reached

I am redownloading the fastq files from the cluster again, just to verify the files, but if there is anything that I should do, based on the error above please let me know.

This is a good first step — it is pretty common for file transfers to become truncated, leaving you with incomplete data. Keep us posted.

Yes! It worked :slight_smile: After downloading all the files from the cluster demux-summary worked perfectly.

Thanks for all your help

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.