demux.qzv doesn't appear following "Moving Pictures" tutorial

Hi, I am new on qiime
I am following the moving pictures tutorial and after running

qiime2-moving-pictures-tutorial]$ *qiime demux summarize *
*> --i-data demux.qza *
> --o-visualization demux.qzv

I get no error but no green .qzv either - when I ls in the directory it is not there.
I’ve followed the tutorial to the letter (the only action has been demultiplexing so far).

Thank you!

Hello @Carlotta. If I understand correctly, your command finished executing without error but doesn’t seem to be producing anything? Can you tell me what version of QIIME 2 you’re running and what kind of environment you’re running it on (native install, HPC, VM, etc.)?

Additionally, can you please run the command again, then run an ls, then upload a screenshot of the resulting terminal?

Thank you.

Hi!
Yes, sure, I am sorry I didn't tell
it is qiime 2-2019.10 and I am not super sure of the environment, it is an interactive session here QIIME2 on Biowulf


Thank you!
Carlotta

Ok @Carlotta to be honest I’m pretty stumped here! It’s not giving you the .qzv. It’s not giving you an error message. It’s not telling you the command was aborted. I’m going to see if any of the other moderators have any ideas.

Thank you @Oddant1! Moreover, going on with the protocol the following .qzv (stats.dad2.qzv) appears (so it is not a qzv problem, if that exist)
Thanks for your help :slight_smile:

Hi @Carlotta - is there any chance that the cluster scheduler is terminating the command? How long did it run for? I think it is almost certainly an issue with the computation environment - perhaps the job is running too long for the resource allocation, or perhaps it is using too much memory/cpu/disk/etc?

Hi @thermokarst, thank you for your prompt response
It runs for less than one minute, so I don’t even need to do a swarm.
Can I ask if I can get the info I would extract from the visualization from somewhere else? for example minimum reads etc?
What would you do? Should I ask Biowulf IT?

You’re welcome!

That is useful info - thanks! It doesn’t necessarily rule out memory/cpu/disk constraints, though. Although, looking at the file sizes in your screenshot above, that seems exceptionally unlikely, too - these files are all super small.

Just to double-check - have you tried running this again? Any chance it was just a one-off fluke? Try running again, with the --verbose flag.

Yes I understand that it is because it is a tutorial and it is on purpose

I've tried to run again with verbose and this happened

@thermokarst and clue? thanks for all this time

I think there might be a misunderstanding - I was just clarifying that my comment about running out of CPU/memory/etc is probably invalid, since you’re working with such a small data set!

Interesting - thanks for sharing! The error in the screenshot isn’t specific to QIIME 2, it looks like an issue with the HPC environment - I suggest contacting the biowulf admins, sending them that screenshot, and asking them for guidance. I am not sure why biowulf is trying to open up a display on your machine - QIIME 2’s q2cli interface (the interface you’re using here) is non-graphical, so there is no reason to open a display. As well, there appears to be some kind of file-permission issue here, related to your home env config. None of this is on you - I’m just giving you some notes on my observations, feel free to pass on to the biowulf admins.

Keep us posted!

Yes, sure!

I will, thanks again a lot for your prompt help, @thermokarst - hopefully I can eventually have that information. Will let you know :slight_smile:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.