Demux quits with plugin error: no Sequences mapped


I am trying to run an analysis on some single end data that is multiplexed. I have my sequences file and my barcodes file. The sequences are in the same order as the barcodes file. When I try and run the demux command I get this error:

Plugin error from demux:

No sequences were mapped to samples. Check that your barcodes are in
the correct orientation (see the rev_comp_barcodes and/or
rev_comp_mapping_barcodes options).

Debug info has been saved to /var/folders/q6/cn1xx_7s097c588sz8n8y04c0000gn/T/qiime2-q2cli-err-yw3147vs.log

I tried every combination (i.e. each alone and both tags together) of adding the reverse complement barcodes/ reverse complement mapping barcodes options but they all give me the same error as above. This is the command I ran:

qiime demux emp-single --i-seqs iowa_raw/iowa_seqs.qza --m-barcodes-file /Users/kirbylab/Desktop/Baylor_3_28_16/mapping_file.txt --m-barcodes-category BarcodeSequence --o-per-sample-sequences iowa_raw/iowa_demux.qza

I'm not sure what is going wrong as I've used a similar dataset to this with no problems. If you could tell me what I've done wrong that would be greatly appreciated! I'm attaching a link to my imported sequences (iowa_seqs.qza) and my mapping file (mapping_file.txt).

mapping_file.txt (43.9 KB)


Hi @saatkinson! It looks like your barcodes and sequences files got swapped when you imported them into iowa_seqs.qza. In other words, barcodes.fastq.gz contains your sequences, and sequences.fastq.gz contains your barcodes. I verified this by exporting your multiplexed data with qiime tools export and inspecting the two .fastq.gz files with the less command.

Can you try re-importing your multiplexed data after you swap those filenames around?

1 Like

Hi @jairideout, Thanks so much for your help! That was definitely the problem; I have no idea how I did that but feel really silly now…


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.