Demux EMPPaired Error without rev-comp-mapping-barcode

Hello,
New QIIME2 user here :clown_face:! I am running across issues when attempting to demultiplex my sequences. I have been looking around the forum to see if anyone has had similar issues, but it looks like many people have the opposite problem, so I am hoping for some guidance as to what I am doing wrong. I’ll try to keep this as brief as possible while giving all the details.

  • I am running qiime2-2019.4 on a mac via conda.

  • I was provided 3 files 1 forward, 1 reverse, and 1 barcode

  • I have imported my files as EMP-paired end sequences following the protocol from the “Atacama Soil microbiome”
    using the command:
    qiime tools import **
    –type EMPPairedEndSequences **
    –input-path non-swapped **
    –output-path end-sequences.qza

  • I am able to import the files no problem, however, I am coming across an issue while demultiplexing.

I originally demultiplexed following the exact commands:

qiime demux emp-paired
–m-barcodes-file bbmetadata.tsv
–m-barcodes-column BarcodeSequence
–p-rev-comp-mapping-barcodes
–i-seqs end-sequences.qza
–o-per-sample-sequences bbdemux.qza
–o-error-correction-details bbdemux-details.qza

qiime demux summarize
–i-data bbdemux.qza
–o-visualization bbdemux.qzv

and received no error and all of my samples were accounted for, however, when looking at my demux.qzv file all of my samples had extremely low sequence counts <1,000…of course I got pretty worried.

I reached out to the lab that did the illumina Miseq library for me and they were able to demultiplex the samples with their illumina cassava program and all of my samples had above 40k sequences which of course a huge relief and fantastic news!

They confirmed that I should be importing as EMP-paired, however, that their barcodes are now forward read and I should eliminate -rev-comp-mapping-barcode from the demux command as the updated EMP primer set no longer requires it, however, when I do that I get the following error:
qiime demux emp-paired
–m-barcodes-file bbmeta.tsv
–m-barcodes-column BarcodeSequence
–i-seqs end-sequences.qza
–o-per-sample-sequences nonsw-demux.qza
–o-error-correction-details demux-details.qza

No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options).

Which is why originally I had assumed it needed the -rev-comp-mapping-barcode…

To troubleshoot:

  • I made sure my forward and reverse files were both equal in size ( just to be sure they downloaded correctly)
  • I re-downloaded and re-imported to ensure I hadn’t swapped files around, but that didn’t work.
  • I tried swapping the froward and reverse files incase they had been named incorrectly that also didn’t work.

I have the demultiplexed files from the lab now, however, I would like to be able to troubleshoot this so I can handle this on my own in the future.
Additionally, I was using the demultiplexing step to subsample from the sequences by creating 3 different metadata files as we had 3 different projects all on one lane and it seemed like the easiest way to separate them out for analysis.

Where could I be going wrong?

Thanks in advance for your help and insight!:poop:
S

Hi @GillSie,
Welcome to the forum and thanks for doing your due diligence in troubleshooting the issue and providing us with lots of details.
A few things come to mind, do you only have barcodes in your forward reads or is this dual-barcoded indexing set up with both forward and reverse reads having barcodes? If the latter, you’ll want to use cutadapts demux-paired plugin to demultiplex instead.
Also, are you sure your barcodes are of 12nt Golay error correcting? By default, the 2019.4 version assumes that this is the case unless you tell it otherwise by setting the --p-no-golay-error-correction parameter.

I would separate these 3 projects at the importing step now that you have them demultiplexed by using separatemanifest files. Saves you time and effort.

Hi @GillSie!

Do you have Golay barcodes? If not, you should disable by setting --p-no-golay-error-correction. If you do have Golay barcodes, perhaps you need to reverse complement the barcode sequences (--p-rev-comp-barcodes), instead of (or maybe in addition to?) the mapping barcodes. Give that a shot and let us know how it goes!

:t_rex:

1 Like

Hi thermokrast & Mehrbod_Estaki!

Thank you both for your input.

Adding --p-no-golay-error-correction did the trick! A quick and easy fix :crazy_face:! I feel I should have caught that.

You both rock and this forum is such a great resource for us newbs :ok_hand:.

Mehrbod_Estaki, thank you for the suggestion on using separate manifest files- I’ll check it out!

Thanks to you both again.
Best,
S

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.