Demulitplexing issue

Hello Qiimers,

I am a newbie here using qiime2-2019-7 version and I encounter my first problem.
I got 3 files R1(2,757,001,216), R2(1,128,349,696 kb), and I1(1,082,059,488 kb) fastq file I gzip my file and imported to qiime but when I am demultiplexing it with these codes.

qiime demux emp-paired
–m-barcodes-file sample-metadata.tsv
–m-barcodes-column barcode-sequence
–p-rev-comp-mapping-barcodes
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux.qza
–o-error-correction-details demux-details.qza

In demux. qza file all I am getting is very low sequences like 20 or 10. I wonder if there is something Iam doing wrong in these code or do I need to change something. I would really appreciate your suggestion.

Please help.

Try the --p-rev-comp-barcodes parameter unless if you know your barcodes are in the correct orientation (you can do a quick search of the raw file to be sure). See if that increases your yield — it is a common cause of this type of issue.

Good luck!

Thanks will do that and update.

Hi Nicolas,
After using this code
qiime demux emp-paired \

--m-barcodes-file sample-metadata.tsv
--m-barcodes-column barcode-sequence
--p-rev-comp-barcodes
--i-seqs emp-paired-end-sequences.qza
--o-per-sample-sequences demux.qza
--o-error-correction-details demux-details.qza

all I am getting is just one sample.
see screenshot.

mapping%20file

Mapping file

look for your barcodes in the raw data. You might just have lots of sequences that do not match your barcodes (e.g., if your data were multiplexed with other peoples’ samples)

you could also try disabling --p-rev-comp-mapping-barcodes though if in your original demux attempt you were getting 10-20 reads for each sample I am guessing there is something wrong in the sequencing — right now there is not really a QIIME 2 technical issue at hand here that I can help with based on what you have shown me, it is just a matter of figuring out the orientation of your barcode reads and whether any actually match your EMP barcodes.

I did try to disable --p-rev-comp-mapping-barcodes
but again getting just one sample in demux.qzv.

Which one is the raw data?

the fastq sequences — I1 from the looks of things

Everything is fine with that file. This data set is already analysed in Usearch but not in Qiime. All I am trying to do is to learn qime with this data set. I dont know what I need to do next. Please help.

Run it with both -p-rev-comp-barcodes and --p-rev-comp-mapping-barcodes. Also, there’s an option to disable Golay barcodes. I’ve been having weird problems with this as well. Ben

1 Like

@Vandana please see this topic for more description of disabling golay error correction (which you should do if your reads are not golay barcodes, e.g., if you are not following the EMP protocol):

That helps, since you should know the correct orientations for demultiplexing and can adapt whatever parameters you used in that analysis. As I suggested above:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.