DEICODE visualization issue in qiime2view

Hi, I’m using DEICODE following this tutorial Robust Aitchison PCA Beta Diversity with DEICODE. When I visualized the .qzv file, the pcoa showed the feature-id near the rows, instead of the taxon-id. I don’t know how to change that. I used a taxonomy.qza file as imput. My script:

qiime deicode rpca --i-table filtered-table.qza --p-min-feature-count 7 --p-min-sample-count 1000 --o-biplot deicode/ordination.qza --o-distance-matrix deicode/distance.qza qiime emperor biplot --i-biplot deicode/ordination.qza --m-sample-metadata-file sample-metadata.tsv --m-feature-metadata-file taxonomy-silva.qza --o-visualization deicode/biplot.qzv --p-number-of-features 8
Thanks a lot!

I wanted to say ‘arrows’, not ‘rows’ :sweat_smile:

Hi @KirKara,
I’d be interested if this is an option as well. At the moment here is my work around for this.
Finalize your plot the way you want and leave the feature-IDs in. On the setting icon at the top click toggle visibility label which should get rid of the arrow-ids but leave the arrows. You can save a high-res PNG of this. Next, on the menu sidebar select Taxon in the sidebar section and save this image now as SVG. With SVG you’ll get a separate legend for your arrows. Finally, to get the regular legend of your groups, you’ll want to do this step again but this time select your grouping factor instead of Taxon. It’s a bit messy and a bit of a pain but it gets the work done. And I’m guessing this is how the DEICODE tutorial figure was made as well?
I hope there’s a friendlier way of doing this in the future.


@Mehrbod_Estaki and @KirKara that is how the DEICODE tutorial figure was made. This is something that will need to be fixed on the emperor side (@yoshiki). If not already done, I would suggest we put in an issue on the emperor GitHub repo with this enhancement request, where both legends can be exported together.

I will try and add some more information to the tutorial next week about using biplots in emperor and more generally.

1 Like

OK, thanks to both of you! @Mehrbod_Estaki @cmartino

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.