Deicode installation error


(Christine Olson) #1

I apologize, but I am getting the following error message upon installation:

Command “/Users/hsiao/anaconda2/envs/qiime2-2018.6/bin/python -u -c “import setuptools, tokenize;file=’/private/var/folders/gm/lw2t4dy92b71m7h3v3yyjyxc0000gn/T/pip-install-rbj0j2t9/hdmedians/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /private/var/folders/gm/lw2t4dy92b71m7h3v3yyjyxc0000gn/T/pip-record-c0gdy9kl/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /private/var/folders/gm/lw2t4dy92b71m7h3v3yyjyxc0000gn/T/pip-install-rbj0j2t9/hdmedians/

Could you please help me figure out the issue? Thank you.


Robust Aitchison PCA Beta Diversity with DEICODE
(cameron martino) #2

Hi Christine @olsonca,

Thank you for reporting the error.

I am guessing from your command that you are using QIIME 2 version qiime2-2018.6. Could you please confirm this?

Additionally, could you please tell me if you are installing DEICODE through conda or pip?

If you are using conda please try using pip in older QIIME 2 versions. This can be done by the following command.

pip install deicode 

The conda installation is not supported for QIIME 2 versions below 2019.1 and will cause issues.


(Christine Olson) #3

Hello,

Thank you for your response. I am using an older version, but I did use pip to install deicode.

I think my issue is that the default mode of Python I am using is 2.7, but now I am trying to switch to using 3 as a default version. I have had issues in switching this on my computer though. Thank you!

Best,
Christine


(Christine Olson) #4

Okay I finally figured it out! Thank you.


(cameron martino) #5

Yes, DEICODE requires python 3.5 or greater. I will add that requirement explicitly in the tutorial / plugin description. Glad it worked out! Feel free to reach out if you have any other issues.


(Christine Olson) #6

Yes, sorry I understood that but was having issues switching versions.

I have another question! When I create the biplot now, all arrows have the long string of numbers and letters without taxa identification (see below). I am wondering how exactly you merge this so you can see which taxa contribute most highly to PCA differentiation? I followed the steps in the tutorial, but I’m not sure if I’m missing something here. Thank you for your help.

Best,
Christine


(cameron martino) #7

Yes, there is, in the biplot command for emperor there is a feature-metadata input parameter that allows you to pass your taxonomy information. Following the moving pictures tutorial this would be

qiime emperor biplot \
    --i-biplot ordination.qza \
    --m-sample-metadata-file sample-metadata.tsv \
    --m-feature-metadata-file taxonomy.qza \
    --o-visualization biplot.qzv \
    --p-number-of-features 8

where the specific input you are looking for is the following line to be incorporated to the usual biplot command

--m-feature-metadata-file taxonomy.qza

You can then turn off or on the arrow labels the labels in the “more options” pop-out box in the top corner.

You can then color the arrows by taxonomy by scrolling to the bottom of the box with which you color the samples.

you will get a legend of something like the following which can be exported as an svg in the “more options” section.

If you would like to copy the original ID of the arrow, just double click on the arrow in the plot and it will be saved to your clipboard.

One more note about interpreting the arrows. It is important to note that a single arrow is not directly related to the features causing sample clusters. It is the log ratio between two features represented by arrows pointing in different directions.

Hope this helps.