Deblur multiple sequencing alignment (MSA) failed by message "may be only 1 read?"

I am using Deblur denoise for 32 samples. At denoising step analysis failed at MSA and showing message "msa failed for file/xyz .fastq.gz.trim.derep.no_artifacts (maybe only 1 read?)".
In the same log file, it shows: "total sequences 7389298, passing sequences 7389298, failing sequences 0".
Can anyone help me to resolve this issue? My log file is attached here
deblur_log.txt (196.5 KB)

My samples are 150bases long and I am giving following command:
conda activate qiime2-2023.5
qiime deblur denoise-16S
--i-demultiplexed-seqs demux-filtered.qza
--p-trim-length 147
--p-jobs-to-start 96
--o-representative-sequences rep-seqs-deblur.qza
--o-table table-deblur.qza
--o-stats deblur-stats.qza

Hello @deepak,

Would you mind sharing the demux summary?

1 Like

Hi @colinvwood I am sharing summary file here.
single-end-demux.qzv (289.0 KB)

This is shotgun sequencing data, and each file is approx. 2-4GB.

Hello @deepak,

This is shotgun sequencing data

There's your problem right there. From the documentation:

Perform sequence quality control for Illumina data using the Deblur workflow
with a 16S reference as a positive filter. Only forward reads are supported
at this time. The specific reference used is the 88% OTUs from Greengenes
13_8. This mode of operation should only be used when data were generated
from a 16S amplicon protocol on an Illumina platform.
The reference is only
used to assess whether each sequence is likely to be 16S by a local
alignment using SortMeRNA with a permissive e-value; the reference is not
used to characterize the sequences.

Thank you so much for this information. Here is one more query, how can I use this 16S reference as a positive filter in Deblur workflow.

Should I use this command?

qiime deblur denoise-other
--i-demultiplexed-seqs single-end-demux.qza
--i-reference-seqs gg_2022_10_backbone_full_length.nb.qza

--o-table ARTIFACT FeatureTable[Frequency]
The resulting denoised feature table. [required]
--o-representative-sequences ARTIFACT FeatureData[Sequence]
The resulting feature sequences. [required]
--o-stats ARTIFACT Per-sample stats if requested.
DeblurStats [required]

Thanks in advance.

Hello @deepak,

The --p-reference-seqs option takes an artifact of FeatureData[Sequence] type. This is a collection of sequences that will be used as a positive filter. You could create such an artifact by importing a database that's in fasta format for example.

I don't know if this makes any sense for your situation, it would depend on the source of your shotgun sequencing data.

We did sequencing on Illumina NovaSeq sequencer.

Hello @deepak,

The sequencing technology is not the issue, but the type of sequences. Deblur is designed for amplicon sequences. Shotgun sequencing is fundamentally different. Really you shouldn't use deblur in any capacity for this sort of data.

Ok, Thank you so much for your prompt response, Now I will try Shogun for my data. I used qiime-mOTU plugin, but I do not know how to analyze alpha diversity from that output because mOTU does not give representative-sequences.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.