Deblur error : all of the sequences are artifacts like PhiX or adapter.

Hi, I am working with paired-end sequences. After joining reads with join-pairs and quality filter using q-score, I used deblur with different trim length, as suggested by the forward-seven-number-summaries.tsv. However I keep getting this error-
"Plugin error from deblur:
No sequences passed the filter. It is possible the trim_length (226) may exceed the longest sequence, that all of the sequences are artifacts like PhiX or adapter, or that the positive reference used is not representative of the data being denoised.
Debug info has been saved to /tmp/qiime2-q2cli-err-kpuvojjm.log"

I have also used cutadapt to remove any adapters, still it gives the same error.
Interestingly, I have used the same dataset before in deblur and I got output.
But now, for some reasons, I cannot get past this error.
Please help. I am attaching all relevant files.

  1. forward-seven-number-summaries.tsv (24.2 KB)
  2. demux-joined-filter-stats.qzv (1.2 MB)

Few lines from deblur.log

FO(140703349196608)2021-09-23 15:56:25,806:***********************
INFO(140703349196608)2021-09-23 15:56:25,806:deblurring started
WARNING(140703349196608)2021-09-23 15:56:25,806:deblur version 1.1.0 workflow started on /tmp/qiime2-archive-_xf0z4ma/d33c0a0b-8f9$
WARNING(140703349196608)2021-09-23 15:56:25,807:parameters: {'seqs_fp': '/tmp/qiime2-archive-_xf0z4ma/d33c0a0b-8f9c-4aa6-9e0e-75ec$
INFO(140703349196608)2021-09-23 15:56:25,807:error_dist is : [1, 0.06, 0.02, 0.02, 0.01, 0.005, 0.005, 0.005, 0.001, 0.001, 0.001, INFO(140703349196608)2021-09-23 15:56:25,807:deblur main program started INFO(140703349196608)2021-09-23 15:56:25,807:processing directory /tmp/qiime2-archive-_xf0z4ma/d33c0a0b-8f9c-4aa6-9e0e-75ec7b5a572
INFO(140703349196608)2021-09-23 15:56:25,808:building negative db sortmerna index files
INFO(140703349196608)2021-09-23 15:56:25,808:build_index_sortmerna files ['/home/iasst/miniconda3/envs/qiime2-2021.4/lib/python3.8$
INFO(140703349196608)2021-09-23 15:56:25,860:building positive db sortmerna index files
INFO(140703349196608)2021-09-23 15:56:25,861:build_index_sortmerna files ['/home/iasst/miniconda3/envs/qiime2-2021.4/lib/python3.8$
INFO(140703349196608)2021-09-23 15:57:08,701:processing per sample fasta files
INFO(140703349196608)2021-09-23 15:57:08,701:--------------------------------------------------------
INFO(140703349196608)2021-09-23 15:57:08,701:launch_workflow for file /tmp/qiime2-archive-_xf0z4ma/d33c0a0b-8f9c-4aa6-9e0e-75ec7b5$
INFO(140703349196608)2021-09-23 15:57:47,712:dereplicate seqs file /tmp/tmpdd_eadma/deblur_working_dir/HN-R1_9_L001_R1_001.fastq.g$
INFO(140703349196608)2021-09-23 15:57:47,948:remove_artifacts_seqs file /tmp/tmpdd_eadma/deblur_working_dir/HN-R1_9_L001_R1_001.fa$
ERROR(140703349196608)2021-09-23 15:57:47,957:sortmerna error on file /tmp/tmpdd_eadma/deblur_working_dir/HN-R1_9_L001_R1_001.fast$
ERROR(140703349196608)2021-09-23 15:57:47,958:stdout : [process:1372] === Options processing starts ... ===
Found value: sortmerna
Found flag: --reads

Thank you.

Hi @Garima_Raj,

What happens if you set the trim length to something like 150, or operate only on the forward read data?

Best,
Daniel

Hi @wasade
When I first tried with only the forward sequences with a trim length of 228, it worked. But now it is giving the same error with forward reads also. I have not tried with trim length of 150. I will run and let you know.

Thank you.

Hi @Garima_Raj,

What length are the raw forward reads and what instrument was used to produce the data?

Nest,
Daniel

@wasade
Forward raw reads are 300 bp long. Illumina Miseq platform was used.

Regards,
Garima

Thanks!

Would it be possible to attach the full debug log file that was noted above (or if unavailable, from the most recent failed run)?

Would it also be possible to get the exact command run with deblur?

I'm not familiar with what "forward-seven-number" summaries are. What I suspect is something in the upstream processing is producing output where at least one sequence is too short. When you reran on just the forward data, was this before or after cutadapt?

Best,
Daniel

@wasade
Sorry for the late response. PFA full deblur log file.
deblur.txt (402.1 KB)
Command for deblur on the forward reads only:
qiime deblur denoise-16S
--i-demultiplexed-seqs demux.qza
--p-trim-length 228
--o-representative-sequences rep-seqs-deblur.qza
--o-table table-deblur.qza
--p-sample-stats
--o-stats deblur-stats.qza

Forward-seven-number-summary is generated after/before quality filtering which gives the number of sequences retained at a certain length.
I tried both before and after cutadapt. It gives the same error.
Recently I also tried with a new set of data and got the same error. I used a trim length of 150. PFA log file.
deblur_se.txt (85.1 KB)

Thanks in advance.
Regards,
Garima