deblur denoise-16s error

Hi
We are new to QIIME2-2021.2 usage… and we are not able to get correct solution for the error…
we have followed the following steps to anlyse the datas

  1. our input data is the following format: (Note: input fastq files are from sortmerna analysis output files – rRNA.fastq obtianed in sortmerna using the illumina WGS -demultiplexed paired end raw reads)

qiime tools import
Type: SampleData[JoinedSequencesWithQuality]
manifest file: se-33-manifest.tsv
The seqs were imported as SingleEndFastqManifestPhred33

  1. then quality filtered as described in the moving pictures tutorial.
  2. performed qiime demux summarize.
  3. based on the summary, decided to use –p-trim-length 150 in deblur denoise-16S step.
  4. submitted the qiime deblur denoise-16S with the following inputs.
    Qiime deblur denoise-16S –i-demultiplexed-seqs ADS_dmux-filtered.qza –p-trim-length 150 –o-representative-sequences path/ADS_rep-seqs-deblur.qza –o-table path/ADS_table-deblur.qza –o-stats path/ADS_deblur-stats.qza –p-sample-stats –p-jobs-to-start 90 –verbose

In run, received the following error message, suggest us to solve the issue

(base) [email protected]:~ conda activate qiime2-2021.2 (qiime2-2021.2) [email protected]:~ qiime deblur denoise-16S --i-demultiplexed-seqs /home/srini1/prabu/Q2/QC/ADS_demux-filtered.qza --p-trim-length 150 --o-representative-sequences /home/srini1/prabu/Q2/deblur/ADS_rep-seqs-deblur.qza --o-table /home/srini1/prabu/Q2/deblur/ADS_table-deblur.qza --o-stats /home/srini1/prabu/Q2/deblur/ADS_deblur-stats.qza --p-sample-stats --p-jobs-to-start 90 --verbose
Traceback (most recent call last):
File “/home/srini1/miniconda2/envs/qiime2-2021.2/lib/python3.6/site-packages/q2cli/commands.py”, line 329, in call
results = action(**arguments)
File “”, line 2, in denoise_16S
File “/home/srini1/miniconda2/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 245, in bound_callable
output_types, provenance)
File “/home/srini1/miniconda2/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 390, in callable_executor
output_views = self._callable(**view_args)
File “/home/srini1/miniconda2/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_deblur/_denoise.py”, line 100, in denoise_16S
hashed_feature_ids=hashed_feature_ids)
File “/home/srini1/miniconda2/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_deblur/_denoise.py”, line 192, in _denoise_helper
“of the data being denoised.” % trim_length)
ValueError: No sequences passed the filter. It is possible the trim_length (150) may exceed the longest sequence, that all of the sequences are artifacts like PhiX or adapter, or that the positive reference used is not representative of the data being denoised.

Plugin error from deblur:

No sequences passed the filter. It is possible the trim_length (150) may exceed the longest sequence, that all of the sequences are artifacts like PhiX or adapter, or that the positive reference used is not representative of the data being denoised.

See above for debug info.

enclosed the dropbox link for the files

Hello @prabugr,
The error is saying that no sequences are passing the filter. This means that the trim_length may be too long or your sequences are being filtered out. It might be a combination of both here.

My suggestion would be to disable trimming by setting the trim_length to -1. This will make it so that deblur denoise wont trim your sequences. Hopefully this will allow some sequences to make it through the filter.

Hopefully this helps!
Chloe Herman

1 Like

Hello @cherman2,

I am receiving the same error. When I changed the trim_length to -1 (input:
qiime deblur denoise-16S --i-demultiplexed-seqs demux-joined-filtered.qza --p-trim-length -1 --o-representative-sequences rep-seqs.qza --o-table table.qza --p-sample-stats --o-stats deblur-stats.qza)

I received this error:
Plugin error from deblur:

No sequences passed the filter. It is possible the trim_length (-1) may exceed the longest sequence, that all of the sequences are artifacts like PhiX or adapter, or that the positive reference used is not representative of the data being denoised.

Debug info has been saved to /tmp/qiime2-q2cli-err-colz0i8y.log

Any suggestions?
I’m very new so any thoughts would be appreciated :slight_smile:

Hey @Mpirtle,
Welcome to the [email protected] community :qiime2:
I am not sure why that isn't working for you.
It is probably because there is a different issue with your demux-joined-filtered.qza. Could you upload your demux-joined-filtered.qzv so that I can take a look at your data and get a better idea of what is happening?
Chloe :turtle:

demux-joined-filtered.qzv (296.3 KB)

Hi Chloe!

I'm hoping that worked :slight_smile:
Thanks,
MP

Hey @Mpirtle,
Looking at your data nothing strikes me as wrong.
The only thing I can think of that might be causing this is the fact that deblur is a work flow that does quality control for Illumina data only. Is this Illumina data?
If your data is not 16s amplicon protocol from an Illumina platform then you might not get any sequences through. Here is the Doc for the [deblur denoise -16s] (denoise-16S: Deblur sequences using a 16S positive filter. — QIIME 2 2021.2.0 documentation) command. It might help to take a look at it and understand the nuances of deblur.
I hope that helps!
Chloe :turtle:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.