dada2 denoise / stats.qza problem

Hi !
I'm having a problem with the dada2 denoising step that I was hoping I could get some help on.
a bit of background on my data: I'm using a dataset of previously published data, there are 100 samples, demultiplexed with a mean of 90,000 reads per sample. the quality score is at 30 for all reads(length 150).

this is the error I get:

Loading required package: Rcpp
Error rates could not be estimated (this is usually because of very few reads).
Error in getErrors(err, enforce = TRUE) : Error matrix is NULL.
Execution halted
Traceback (most recent call last):
File "/opt/conda/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_dada2/", line 264, in denoise_paired
File "/opt/conda/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_dada2/", line 36, in run_commands, check=True)
File "/opt/conda/envs/qiime2-2021.2/lib/python3.6/", line 438, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['run_dada_paired.R', '/tmp/tmpk2at78sx/forward', '/tmp/tmpk2at78sx/reverse', '/tmp/tmpk2at78sx/output.tsv.biom', '/tmp/tmpk2at78sx/track.tsv', '/tmp/tmpk2at78sx/filt_f', '/tmp/tmpk2at78sx/filt_r', '150', '150', '2', '2', '2.0', '2.0', '2', 'independent', 'consensus', '1.0', '10', '1000000']' returned non-zero exit status 1.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/opt/conda/envs/qiime2-2021.2/lib/python3.6/site-packages/q2cli/", line 329, in call
results = action(**arguments)
File "", line 2, in denoise_paired
File "/opt/conda/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/", line 245, in bound_callable
output_types, provenance)
File "/opt/conda/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/", line 390, in callable_executor
output_views = self._callable(**view_args)
File "/opt/conda/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_dada2/", line 279, in denoise_paired
" and stderr to learn more." % e.returncode)
Exception: An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

Plugin error from dada2:

An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

See above for debug info.

my script :slight_smile:

qiime dada2 denoise-paired
--i-demultiplexed-seqs demux.qza
--p-trim-left-f 2 \ ( I've tried 0 for this flag as well)
--p-trim-left-r 2 \ ( I've tried 0 for this flag as well)
--p-trunc-len-f 150
--p-trunc-len-r 150
--o-representative-sequences rep-seqs.qza
--o-table table.qza
--p-n-threads 10
--o-denoising-stats stats.qza

Hi @Anahid_Amani_Moghada,

Thanks for reaching out! Here's where the issue lies:

Essentially, not enough reads passed the denoising/filtering steps and thus error rates could not be estimated.

Can you run qiime demux summarize on your demultiplexed sequences and share what the interactive quality plot looks like from that visualization? I'd be interested to see what that looks like to make sure that the truncation parameters you've chosen aren't unintentionally filtering out all of your reads. Thanks! :lizard:

hi @lizgehret .
here is a screenshot from the reads quality:

Hi @Anahid_Amani_Moghada,

Thanks for following up with that screenshot! It looks like you have binned quality scores - is your data by chance NovaSeq or iSeq? And do you know if any quality control or filtering have been performed on it prior to your analysis? Check out this related forum post with a similar looking quality plot; if this is the case, you will most likely want to use deblur instead of dada2!

Cheers :lizard:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.