dada2 denoise-paired no features remaining

Hello,

I have just recently started working with qiime2 (version 2020.8), and I am trying to work through the initial steps using my old paired-end fastaq files. The forward and reverse files were already demultiplexed from the person who sequenced them. I was able to import them without a problem, but I started to run into issues when running the dada2 denoise-paired code. Below is the code that I used, from the import to the error I get:

qiime tools import \

–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path qiime-import-practice
–output-path testing_file.qza
–input-format PairedEndFastqManifestPhred33V2

Imported qiime-import-practice as PairedEndFastqManifestPhred33V2 to testing_file.qza

qiime demux summarize \

–i-data testing_file.qza
–o-visualization demux-summary-test.qzv

Saved Visualization to: demux-summary-test.qzv

qiime dada2 denoise-paired \

–i-demultiplexed-seqs testing_file.qza
–p-trim-left-f 5
–p-trim-left-r 5
–p-trunc-len-f 290
–p-trunc-len-r 290
–p-chimera-method pooled
–o-table table-test.qza
–o-representative-sequences rep-seqs-test.qza
–o-denoising-stats denoising-stats-test.qza

Plugin error from dada2:

No features remain after denoising. Try adjusting your truncation and trim parameter settings.

Debug info has been saved to /var/folders/mq/dv8ks0ns3pgc0jy9ltrnf7p80000gn/T/qiime2-q2cli-err-31b72ezf.log

I tried adjusting the parameters like it says, even having both at zero, and I get the same error. I am worried that it may be either the formatting of my fastaq files, or that the quality of them is just too low to do this. Below is one sequence from a forward (top) and reverse (bottom) read of a sample. Additionally, I have added the demux summary image in case that is of help in figuring out this problem:

@M04021:39:000000000-CBCP8:1:1101:12166:3705 1:N:0:TAAGGCGA+AAGGAGTA
GTGCCAGCCGCCGCGGTAATACGTAGGGTGCAAGCGTTAATCGGAATTACTGGGCGTAAAGCGTGCGCAGGCGGTTATATAAGTCAGATGTGAAATCCCCGGGCTCAACCTGGGAACTGCATTTGAGACTGTATAGCTAGAGTACGGTAGAGGGGGATGGAATTCCGCGTGTAGCAGTGAAATGCGTAGATATGCGGAGGAACACCGATGGCGAAGGCAATCCCCTGGACCTGTACTGACGCTCATGCACGAAAGCGTGGGGAGCAAACAGGATGAGATACCCTGGTAGTCCACGCCCTA
+
[email protected][email protected]?FCFGGGFFFDFFDFGGEEEGCD<BBFGGGGFEFCFFFA9CBDFFCABFF9BFF,@FDG<[email protected]EFGGGGEG:BE:::,?FFGEFE?FFCF7?<<<BCCEC;EE??7BCFDDEG>C+8<4?>[email protected];CGGG?7<:<)9BCC;(;5+:8CB?FF:>:D8:>99:>9:(:7F?FF7+5:>>?+<+.2;([email protected]<A,7)440,.

@M04021:39:000000000-CBCP8:1:1101:12166:3705 2:N:0:TAAGGCGA+AAGGAGTA
GGTGTGTTGCCCGTGTCGGCTTCACTCCTCCACTGCTTAGACGTCGCCAGTACCACCACTGCCCACGCCCACCCCCTCCCTCTTTACTGCCCCTACTGCACGCAGGCTGGGGCACCACACGTGTCTCCATCGCCTGGTACTCCACTCTCTCCACTTTGTCCTGTGGTTGTTGGTTTTTCACTGTCTCAGTACCGAAGCTACCGGGTTCGCTTGCCCGCAGGGGGAGTACGGCCGCCAGTTTGACGCTTCGGGGAATTGCCGCCGTTCACCGCCCCCTTCTGACCTCCTTTCCCTCGGGAGC
+
-,(()(((((,((,(,)))((,(((,(4.(-(.)((-(((-(())-.0,-,0.(((3)3,1-)994/,((((4)8.)(((,()0+1)2/1).((4(**0;;9+)22,20***+***1.2.7.0+6<1)8+2230==*34>F<<8,7,8388,@@@,88*,3,7C5*5+53+*@3++<+88+F:D>,+88++3::>B9,[email protected]++,<,5,8+8+6+,++++++7,66,66,6,;6,=,8++,+,-A8


(I hope these upload right!)

Any help would be greatly appreciated! If any other information you would think could be helpful I can try and provide you.

Thank you in advance for your time!
John

1 Like

Hi @John_Kincaid,

Welcome to the :qiime2: forum!

I agree with you - I think your data may potentially be too low quality to allow denoising. In particular, your reverse reads are bad. So, if I were you, my first trouble shooting step would be to try denoising your forward reads alone, see how that works, and then consider what happeens when you add the reverse reads.

And to be honest, I might be wary of data of this quality in general - can you contact your sequencing provider to see if they’ll give you a re-sequence for free?

Best,
Justine

2 Likes

Thank you for your help Justine!

We believe that the files we were using had some kind of different formatting, mainly because when done with RDP pipeline we observed good quality sequences in that same plot (up to the 40 marker). We had a different sequencing event this year and we got fastaq files that worked perfectly this time around, with good quality sequences using QIIME2.

Thank you again,
John

Hi @John_Kincaid,

Is your PHRED score in the correct format?

Best,
Justine

It is very unusual that the early bases would be lower quality than the later bases in Illumina sequencing. Is it possible that your reverse reads are “reversed” – that is reversed prior to delivering them to you by your seaquencing provider?

That would explain both the unusual quality score profile for your reverse reads, and the zero paired reads making it through denoised-paired processing – which assumes that the data are in the normal orientations.

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.