dada2 denoise issues: plugin error from dada2.

hi there,

i am using qiime2 2019.4 on a virtual box machine with everything going well until i tried to denoise my data using dada2. I typed the following and received the following response. Can anyone assist with what I have done wrong?

(qiime2-2019.4) [email protected]:~/Downloads$ source activate qiime2-2019.4
(qiime2-2019.4) [email protected]:~/Downloads$ qiime dada2 denoise-paired \

–i-demultiplexed-seqs demux-paired-end.qza
–p-trim-left-f 0
–p-trunc-len-f 265
–p-trim-left-r 0
–p-trunc-len-r 190
–o-representative-sequences rep-seqs.qza
–o-table table.qza
–o-denoising-stats stats.qza
Plugin error from dada2:

An error was encountered while running DADA2 in R (return code -9), please inspect stdout and stderr to learn more.

Debug info has been saved to /tmp/qiime2-q2cli-err-testnskl.log
(qiime2-2019.4) [email protected]:~/Downloads$ ^C

thank you in advance,

Tess

Welcome to the forum, @tessabell8!

This is a memory error, and is a common problem; easiest solution is to get a more powerful machine! You can check out these posts in the forum for more detailed advice:
https://forum.qiime2.org/search?q=An%20error%20was%20encountered%20while%20running%20DADA2%20in%20R%20(return%20code%20-9)

Good luck!

Hi,

Thank you for your reply. I was running QIIME2 on my laptop at first and was told it wouldn’t be able to handle it. So I then tried again on a super computer with more than enough memory and received the same message as above.

Chat with your HPC admin. You may not be requesting enough resources for your job. It should not take an enormous amount of RAM — 32 GB should be much more than enough.

An older laptop may have trouble, but q2-dada2 and most other QIIME 2 can get by with very little memory. I use an 8GB laptop that is a few years old and can analyze most “normal-sized” datasets on that computer. Very large or diverse datasets (i.e., result in many many more unique sequences) increase the memory demand, and this is when access to an HPC is necessary.