DADA2 -11 exit code (paired-end reads)

Hi @thermokarst,

Yes I did upload a file, but I can’t see it either! I used the upload button here and the upload was successful although I can’t see the uploaded file.

Is there a better way of sharing the data?

Thanks

It’s probably too big for our forum :frowning: Do you have a google-drive or dropbox link you could create/share?

Thanks!

Hi @thermokarst,

Yes that was before I made the Rprofile changes. Unfortunately I didn’t save that error log, too bad!

Now the moving pictures tutorial has worked for me so, may be the error was related to the Rprofile (but as you mentioned, I can’t prove this without the error log)

Thanks again

Hi @ebolyen and @thermokarst

Doest this work?

2 Likes

@thermokarst can reproduce the issue!!! Thanks so much! We can start actually debugging the code now to see what’s going on under the hood. Stay tuned!

1 Like

@ebolyen

@thermokarst can reproduce the issue!!! Thanks so much! We can start actually debugging the code now to see what’s going on under the hood. Stay tuned!

Thanks for letting me know!

Shot in the dark here, but would you be able to run the following:

conda create -n DONOTUSE --file https://data.qiime2.org/distro/core/qiime2-2017.12-conda-osx-64.txt
source activate DONOTUSE
wget -qO- https://forum-qiime2-org.s3-us-west-2.amazonaws.com/original/1X/ac621debfd04f561bf1075b4efa56c0e947a1928.txt > which run_dada_single.R
wget -qO- https://forum-qiime2-org.s3-us-west-2.amazonaws.com/original/1X/07fa5193f904022996a35a963b12b9ac79dbb1f4.txt > which run_dada_paired.R

This is going to overwrite some stuff which might help. Then run dada2 like normal on your dataset.

I have finished running these scripts and am currently running dada2 on the data that I shared. I will let you know how it goes!

Your continued help is highly appreciated

Hi ebolyen,

This worked for my own data! Thank you! Are you going to fix it in the qiime2-2017.12 release? Do we need to reinstall?

I got the same problem on my Ubuntu 14.04, qiime2-2017.12

Plugin error from dada2:

An error was encountered while running DADA2 in R (return code -11), please inspect stdout and stderr to learn more.

Debug info has been saved to /tmp/qiime2-q2cli-err-lgevf14g.log

Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_paired.R /tmp/tmp8ct42kir/forward /tmp/tmp8ct42kir/reverse /tmp/tmp8ct42kir/output.tsv.biom /tmp/tmp8ct42kir/filt_f /tmp/tmp8ct42kir/filt_r 300 300 0 0 2.0 2 consensus 1.0 0 1000000

R version 3.4.1 (2017-06-30)
Loading required package: Rcpp
DADA2 R package version: 1.6.0

  1. Filtering …
  2. Learning Error Rates
    2a) Forward Reads
    Initializing error rates to maximum possible estimate.
    Sample 1 - 34346 reads in 32495 unique sequences.

*** caught segfault ***
address 0x8, cause ‘memory not mapped’

We have just released a patched update to q2-dada2 that appears to fix this :crossed_fingers: . Please follow the instructions here to get your hands on the patch, and please let us know how it goes! Thanks so much for all the support while we were debugging this! :t_rex:

Hi @thermokarst,

Thank you for this update and thank you again to the entire Qiime2 group working together to help all of us! I will follow the instructions on the above update and will let you know you.

FYI - I tried the (DONOTUSE) option that @ebolyen suggested earlier. It worked for a subset of my data although it really took long to finish, then I tried it on my entire data but it’s almost 48 hrs now and it’s still running! I will terminate it!

Kind regards

2 Likes

Hi @thermokarst @ebolyen

All worked for me!

Thank you so much

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.