Cutadapt trim iontorrent data

(Bahtiyar Yilmaz) #1

Dear Matthew,

I have an Iontorrent 16S data within a single fastq file for 72 samples. I followed the @shwane’ s advice and managed to come until the generation of trimmed-seqs.gza file and here are the command line that I have run since the beginning.

qiime tools import --type MultiplexedSingleEndBarcodeInSequence --input-path WildMice_Chip1.fastq.gz --output-path multiplexed-seqs.qza

qiime cutadapt demux-single --i-seqs multiplexed-seqs.qza --m-barcodes-file shwanesample-metadata.tsv --m-barcodes-column BarcodesSequence --p-error-rate 0 --o-per-sample-sequences demultiplexed-seqs.qza --o-untrimmed-sequences untrimmed.qza --verbose

qiime cutadapt trim-single --i-demultiplexed-sequences demultiplexed-seqs.qza --p-front ATTAGATACCCYGGTAGTCC --p-error-rate 0 --o-trimmed-sequences trimmed-seqs.qza --verbose

qiime demux summarize --i-data trimmed-seqs.qza --o-visualization trimmed-seqs.qzv (Please see the gzv file in attachment)

I’d like to generate the rep-seqs.qza and table.gza that I can carry out with analysis. However, I couldn’t figure it out from the command line. Can you guide me for me that?

Thanks a lot.

Best,
Bahti

trimmed-seqs.qzv (299.0 KB)

0 Likes

Demultiplexing and Trimming Adapters from Reads with q2-cutadapt
(Bahtiyar Yilmaz) #2

Actually I managed to follow on analysis with following commands until the taxonomy part. Here is I need help to create taxonomy.gza file.

First when I run qiime feature-classifier classify-sklearn --i-classifier gg-13-8-99-nb-classifier.qza --i-reads rep-seqs_120.qza --o-classification taxonomy.qza

It says ValueError: gg-13-8-99-nb-classifier.qza was created by ‘QIIME 2019.1.0’. The currently installed framework cannot interpret archive version ‘5’. That’s fine because I am using qiime2-2018.8-1 and assuming that this is the problem.

Then I decided to create gza file myself from 97% OTU GG database.

singularity exec /software/singularity/containers/qiime2-2018.8-1.debian9.simg qiime tools import
–type ‘FeatureData[Sequence]’
–input-path 97_otus.fasta
–output-path 97_otus.qza

singularity exec /software/singularity/containers/qiime2-2018.8-1.debian9.simg qiime tools import
–type ‘FeatureData[Taxonomy]’
–input-path 97_otu_taxonomy.txt
–output-path ref-taxonomy.qza

It says
There was a problem importing 97_otu_taxonomy.tsv:
** 97_otu_taxonomy.tsv is not a(n) TSVTaxonomyFormat file**.

And it doesn’t accept the –source-format HeaderlessTSVTaxonomyFormat to be added into commands as shown here https://docs.qiime2.org/2017.7/tutorials/feature-classifier/.

Basically I need create classifier to run qiime feature-classifier classify-sklearn commands. My sequence is from Iontorrent and it is for V5-V6 region.

Thank you very much for your help.

Best wishes,
Bahti

0 Likes

(Nicholas Bokulich) #3

I recommend installing the latest version of QIIME 2. It looks like you are using different old versions of the software and even older versions of the documentation.

That’s because you are looking at an archived version of the documentation that is almost 2 years old. That parameter is now called --input-format I believe.

If you have version 2019.1 installed, you can use one of the full-length 16S classifiers from the QIIME 2 site.

Try using the updated parameter name I mentioned above — if that does not work you should manually inspect the file to see what the problem is.

Good luck!

0 Likes

(Bahtiyar Yilmaz) #4

Thanks a lot Nicholas. I did as you said and it worked beautifully. Cheers,
Bahti

1 Like

(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.

0 Likes