cutadapt in qiime2-2022.11

sample_id.csv (575 Bytes)
cutadapt_trimming.log.txt (809 Bytes)
env_log.txt (3.1 KB)
list_log.txt (48.3 KB)
qiime_info_log.txt (782 Bytes)
Hello Forum,

I am running qiime2 on a virtual machine (Hyper V manager, Windows 10 professional) and I am stuck at the step where I am trying to remove the primer and adaptor sequences from it (qiime2 cutadapt error-screenshot attached). I also generated a log. (154.3 KB)
Processing: qiime2-cutadapt error screenshot.JPG...
sample_id.csv (575 Bytes)

file for the command (cutadapt_trimming.log - attached) which states "These commands cannot be manually re-run as they will depend on temporary files that no longer exist".

The input files are paired end in Fastq.gz file format (sample id file - attached).

I found a previous conversation where another user had a similar problem and tried to follow the suggested remedy for the situation but the thread was closed even before it was properly solved.

I tried the suggested commands env (env_log.txt - attached) and conda list (list_log.txt -attached) and qiime info (qiime_info_log) but then i don't know how to proceed from there. (154.3 KB)

Hi @D_S,

Welcome to the :qiime2: forum!

Thanks for providing all of these details - from the traceback you provided, it looks like the error is coming from this line:

ModuleNotFoundError: No module named 'cutadapt'

There is probably something fishy going on with your conda environment - can you please run the following command (while in your qiime2-2022.11 environment), and copy/paste the results in your response:

qiime info

Thanks! :lizard:

Hi @lizgehret,

Thanks a lot for the response.
Here's the output for the command "qiime info" under the qiime2-2022.11 environment:

(qiime2-2022.11) mih@hvubuntusvr01:~/JR2_qiime2$ qiime info
System versions
Python version: 3.8.15
QIIME 2 release: 2022.11
QIIME 2 version: 2022.11.1
q2cli version: 2022.11.1

Installed plugins
alignment: 2022.11.1
composition: 2022.11.2
cutadapt: 2022.11.1
dada2: 2022.11.2
deblur: 2022.11.1
demux: 2022.11.1
diversity: 2022.11.1
diversity-lib: 2022.11.1
emperor: 2022.11.1
feature-classifier: 2022.11.1
feature-table: 2022.11.1
fragment-insertion: 2022.11.1
gneiss: 2022.11.1
longitudinal: 2022.11.1
metadata: 2022.11.1
phylogeny: 2022.11.1
quality-control: 2022.11.1
quality-filter: 2022.11.1
rescript: 2023.2.0
sample-classifier: 2022.11.1
taxa: 2022.11.1
types: 2022.11.1
vsearch: 2022.11.1

Application config directory

Getting help
To get help with QIIME 2, visit


Hi @D_S,

That's interesting - you do have cutadapt under the list of qiime plugins within your environment. Can you also run conda list and provide that output as well? It might be fairly long, so feel free to include that output in a text file and attach it in your response. Thanks! :lizard:

Hi @lizgehret,

Thanks again.
attached you can find the conda_list.txt file.

list_log.txt (48.3 KB)

Hi @D_S,

Thanks for sharing that! It looks like you have both the base cutadapt package, as well as q2-cutadapt (the QIIME 2 plugin that wraps cutadapt). Can you try running qiime cutadapt --help in your same conda environment, and share the output? Thanks! :lizard:

Hi @lizgehret,

Here's the output after running the qiime cutadapt --help command:

Usage: qiime cutadapt [OPTIONS] COMMAND [ARGS]...

Description: This QIIME 2 plugin uses cutadapt to work with adapters (e.g.
barcodes, primers) in sequence data.

Plugin website: GitHub - qiime2/q2-cutadapt

Getting user support: Please post to the QIIME 2 forum for help with this

--version Show the version and exit.
--example-data PATH Write example data and exit.
--citations Show citations and exit.
--help Show this message and exit.

demux-paired Demultiplex paired-end sequence data with barcodes in-
demux-single Demultiplex single-end sequence data with barcodes in-
trim-paired Find and remove adapters in demultiplexed paired-end
trim-single Find and remove adapters in demultiplexed single-end


@D_S very interesting... Okay let's just try having you run your initial command once more (making sure to include the --verbose command) and see if we get the same error message as before.

Hi @lizgehret
yes, still getting the same error message as before.
Please check the jpeg for the screenshot and the log file for the error message.

cutadapt_trimming1.log.txt (809 Bytes)

Hi @D_S,

Well, thanks for giving that a try! Let me try to replicate this issue on my end - do you mind sharing your seqs.qza file with me? DM is fine if you'd prefer not to share publicly on the forum.

Cheers :lizard:

Hi @lizgehret,

Thank you for your continuous support. Unfortunately, the .qza file size exceeds the maximum size limit (7.9Mb) for sending it here. If you could provide me with an email address, I'd be grateful, and will send it over to you (around 59Mb in size).

Best regards,

Hi @lizgehret,

Please check the link below for downloading the file.

Thanks again,

Hi @D_S,

Thanks for sharing that file - I was able to run this successfully on my end. It seems like there's most likely an issue with your conda environment. Here's what I'd recommend - I would delete your 2022.11 environment (via conda deactivate and then conda env remove -n qiime2-2022.11, run conda clean --all, and then re-install a new QIIME 2 environment. You can either re-install 2022.11 (if you need that version to maintain consistency across your analysis) or you can install our latest version - 2023.5.

Cheers :lizard:

Hi @lizgehret

Thanks for your help.
I uninstalled the previous version (qiime2-2022.11) and checked and removed any other discoverable environments with "conda info --envs" and "conda env remove ..." commands.
Installed the latest version and everything seemed fine until the cutadapt command and it resulted in a similar error as before: please check the .jpeg (verbose)

cutadapt_trimminglog.txt (808 Bytes)
and log.txt files for details