"curl -sL" not working on my Mac when following the tutorial

Dear Qiime2 masters,
I just installed qiime2 on my Mac by following the instruction on qiime2 website. When I tried to follow the “Moving Pictures” tutorial, it seems the command:
curl -sL “https://docs.google.com/spreadsheets/d/1_3ZbqCtAYx-9BJYHoWlICkVJ4W_QGMfJRPLedt_0hws/export?gid=0&format=tsv” > sample-metadata.tsv

was not working. The generated sample-metadata.tsv file was empty (0 bytes). But if I directly copy and paste the https address, I can download the correct file to my Mac.
The same things happened when I tried to download the barcodes.fastq.gz and sequences.fastq.gz. So I downloaded them by direct copy-paste the web addresses. The rest of the tutorial ran well.
I am wondering if you have any ideas about the “curl -sL” problem. Thanks!

Kind regards,

1 Like

Hi @agan, thanks for contacting us! Sorry to hear that curl is causing you some problems. We have had reports of older versions of curl causing problems for some people. This most likely has to do with security certificates, and how the curl client interacts with them.

One workaround is to disable certificate checking (this is done by appending -k to the curl command, e.g. curl -sLk "https://example.com"). As well, you can copy and paste the addresses into a web browser and manually download that way (it sounds like that was the route you took already). If you are working in a command-line only environment, you can either upgrade to a recent version of curl, or you can use another command-line download client, like wget, if you don’t want to disable certificate checking. Generally speaking, disabling those certificate checks is considered a bad practice, but for the sake of downloading these data, it really doesn’t matter (in my opinion). Again, sorry for the hassle, we will revise our documentation with a new/alternate solution. Thanks!

1 Like

Thanks a lot for your prompt reply, Matthew.
Yes, the problem was solved by appending -k. Thanks!

1 Like