Create barcode file

Hi, I am new in qiime2 and I do not find how to create the barcode.fastq.gz file. I have a mapping file (which conteins a column with the barcodes and 2 fastq.gz files whit the sequences. Can ou help me? Thanks

Hi @cecibe,
Where your barcodes are is all going to depend on how you constructed your sequencing library. Your 2 fastqs are probably the forward/reverse reads, and the barcodes may be in-line in the sequences or in the header lines — it is impossible to know without getting that information from the source (or you could check the first N nucleotides on each sequence to see if these match the barcodes in your sample metadata file). Check with the sequencing center, lab, or whoever did the library prep/sequencing, that’s the surest way to know.

Once you figure out where the barcodes are, I can point you in the direction of the correct method for importing/demultiplexing.

Good luck!

Hi Nicholas, thaks for your help. I checked the first lines of my sequences and I found that the barcodes are in the sequences (the first 8 nucleotides) Can you give point me the correct method for doing the barcodes.fastq. gz file I need? thanks a lot!

Hi @cecibe,

Excellent! There is no need to create a barcodes.fastq file. This tutorial covers the data type that you describe. See the note at the bottom of the tutorial for how to use paired-end data (as you have), since the steps provided are actually for single-end reads.

I hope that helps!

Hi Nicholas, thanks a lot for your help. I did what you told me before and I have now other error messages:
Plugin error from cutadapt:

/tmp/qiime2-archive-vy23qd4b/4f213eec-1cd8-4539-be27-4de892120423/data/reverse.fastq.gz is not a file.

Debug info has been saved to /tmp/qiime2-q2cli-err-ea0vocis.log

Can you help me again?

Cecilia

Hi @cecibe,
Could you please specify the command that you are running, and provide the full error message? (that message will either be in that log file, /tmp/qiime2-q2cli-err-ea0vocis.log, or you can display by running that command with the --verbose flag)

Thanks!

I wrote:
qiime cutadapt demux-paired --i-seqs prueba.qza --m-forward-barcodes-file metadate.tsv --m-forward-barcodes-column BarcodeSequence --o-per-sample-sequences demultiplexed-seqs.qza --o-untrimmed-sequences untrimmed.qza
And it appered:
Plugin error from cutadapt:

/tmp/qiime2-archive-vy23qd4b/4f213eec-1cd8-4539-be27-4de892120423/data/reverse.fastq.gz is not a file.

Debug info has been saved to /tmp/qiime2-q2cli-err-ea0vocis.log

Could you please run that command again, but add --verbose to the end of the command? And share the output here.

Please also share the commands that you used to import your sequences to prueba.qza, and list the contents of the sequences directory that you imported (you can use ls name_of_folder).

Thank you.

I imported whit:
(qiime2-2018.2) [email protected]:~/Documentos$ cd prueba
(qiime2-2018.2) [email protected]:~/Documentos/prueba$ ls
forward.fastq.gz reverse.fastq.gz
(qiime2-2018.2) [email protected]:~/Documentos/prueba$ cd …
(qiime2-2018.2) [email protected]:~/Documentos$ qiime tools import --type MultiplexedPairedEndBarcodeInSequence --input-path prueba --output-path prueba.qza
(qiime2-2018.2) [email protected]:~/Documentos$ ls
341 metadate.tsv prueba prueba.qza

Now I wrote:
(qiime2-2018.2) [email protected]:~/Documentos$ qiime cutadapt demux-paired --i-seqs prueba.qza --m-forward-barcodes-file metadate.tsv --m-forward-barcodes-column BarcodeSequence --o-per-sample-sequences demultiplexed-seqs.qza --o-untrimmed-sequences untrimmed.qza --verbose
And appeared this error message:
Plugin error from cutadapt:

/tmp/qiime2-archive-t2i5zu5b/4f213eec-1cd8-4539-be27-4de892120423/data/reverse.fastq.gz is not a file.

Could you please run this command and post the output:

qiime tools validate prueba.qza

This issue may also be related to file system permissions, as described in this thread. Do you want to try running the different diagnostic steps described by the moderator in that thread and see if, e.g., changing your TMPDIR solves the issue?

Thanks!

It answers:
Artifact prueba.qza appears to be valid at level=max
I will follow the tutorial you sent me and I will write again, thanks a lot for your help

Cecilia

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.