Correct --p-metric parameter for beta diversity metric use in qiime longitudinal pairwaise-differences

Dear Developers,
I am trying to use the qiime longitudinal plugin applying the pairwise-differences visualizer to parse microbiome differences between two groups and along two time-points (before and after treatment).
Unfortunately, I am having the same issue reported in the following post (whose question remained unsolved, from my understanding):


that is, when I try to use a beta diversity metric to comparison, I am not able to insert the right --p-metric label.

This is my code:
qiime longitudinal pairwise-differences
–m-metadata-file COHORT_A_LESS_LOST_FU2.txt
–m-metadata-file unweighted_unifrac_pcoa_results.qza
–p-metric Axis 1
–p-group-column Arm
–p-state-column MONTH
–p-state-1 0
–p-state-2 6
–p-individual-id-column studyid
–p-replicate-handling random
–o-visualization pairwise-differences_unweighted.qzv
And this is the error, independently of the use of --verbose at the end of the code:
(1/1) Got unexpected extra argument (1)

If I try to use “Axis 1” or ‘Axis 1’ I receive this error:
Error: Detected invalid character in: ‘Axis, 1’
Verify the correct quotes or dashes (ASCII) are being used.
or
Error: Detected invalid character in: “Axis, 1”
Verify the correct quotes or dashes (ASCII) are being used.
respectively.

I am using the qiime2-2020.2 version on a McBookPro.
Thank you in advance for your help,
Alessandro Lazzaro

If I am not mistaken, I believe you have to put quotes around Axis 1 if you use it as an input. I also think the pairwise-differences function only works for alpha diversity metrics and for beta diversity metrics you would need to use pairwise-distances.

1 Like

Welcome @Alessandro_Lazzaro!

@Zach_Burcham is correct, you need to put quotes around “Axis 1”. I see that you tried that already:

That sounds like exactly what it is saying: an invalid character was detected. Sounds like you were probably copying/pasting into the terminal from another source (website, document) that may have hidden formatting… my advice is to try typing it into the terminal from scratch.

Good luck and thanks @Zach_Burcham!

Oh, thank you for the tip: it worked!

1 Like