Core Metrics ID issue

Hi
So I performed a couple of your recommended filtering steps - first chimera filtering and thencontingency based filtering for singletons for both my feature table and my representative sequences (code below). I did not perform quality filtering - I am working with 454 data, and I do not have fastq files.
Input:

  • filter feature table
    qiime feature-table filter-features --i-table table-nonchimeric.qza --p-min-samples 2 --o-filtered-table table-nonchimeric-gt2.qza

  • Summarize feature table
    qiime feature-table summarize --i-table split-library-output/uchime-dn-out table-nonchimeric-gt2.qza
    –o-visualization table-nonchimeric-gt2.qzv --m-sample-metadata-file sample-metadata.tsv * Number of features = 16529

  • Use filtered feature table to filter rep-seqs
    qiime feature-table filter-seqs --i-data rep-seqs-nonchimeric.qza --i-table table-nonchimeric-gt2.qza --o-filtered-data rep-seqs-nonchimeric-gt2.qza

  • Align using MAFFT (worked fine this time)
    qiime alignment mafft --i-sequences rep-seqs-nonchimeric-gt2.qza --o-alignment rep-seqs-nonchimeric-gt2-aligned.qza

  • Mask alignment
    qiime alignment mask --i-alignment rep-seqs-nonchimeric-gt2-aligned.qza --o-masked-alignment masked-rep-seqs-nonchimeric-gt2-aligned.qza

-Make the tree
qiime phylogeny fasttree --i-alignment masked-rep-seqs-nonchimeric-gt2-aligned.qza --o-tree unrooted-tree2.qza

-Root the tree
qiime phylogeny midpoint-root --i-tree unrooted-tree2.qza --o-rooted-tree rooted-tree2.qza

  • Perform diversity analyses
    qiime diversity core-metrics-phylogenetic --i-phylogeny split_library_output/uchime-dn-out/rooted-tree.qza --i-table split_library_output/uchime-dn-out/table-nonchimeric-gt2.qza --p-sampling-depth 900 --m-metadata-file map_file.tsv --output-dir core-metrics-results-gt2

However, when I run this command I get a similar error to this post Diversity plug-in error where my feature IDs are again missing. I have checked the output table, rep-seqs file, and the tree, and the “missing” features are all present.

Thank you

Laura

Hi @LauraMason!

You switched up which rooted tree you are using - split_library_output/uchime-dn-out/rooted-tree.qza vs ooted-tree2.qza - this could easily account for your ID mismatch issue, but without seeing the exact error, we can’t be too sure.

Can you help us out by providing the following information:

  • What version of QIIME 2 are you using?
  • Can you provide the complete error message? You linked to a similar message, but errors are often highly customized - they might look the same at a cursory glance, but usually reveal a bit of detail specific to the instance upon closer inspection. Please copy and paste the error when run with the --verbose flag, or, attach the file referenced at the end of the error when run without the --verbose flag.

Thanks! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.