core dumped in taxonomy classification

Hi everybody!

I'm trying to classify my sequences by the following script:

time qiime feature-classifier classify-sklearn --i-classifier NCBI_16S_classifier.qza --i-reads 16S_F_representative_sequences.qza --o-classification taxonomy.qza

But i got a core dumped warning after 20 min running. I found the same error during the fit-classifier step after download the 16S sequences from NCBI. I solved it by --p-classify-chunk-size 10000...

I'm using ubuntu in the bash in windows... there is some posibility to reach more space for temp files??

Thank you in advance!!

1 Like

Hello Ana,

Yes! You can set your TEMPDIR as shown here. The new location you use for temp depends on your system setup and which disks have space.

The feature-classifier also uses a lot of RAM, so it might be worth checking on your memory usage while running this script, if you haven't already.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.