‘command not found’ error during import data

Hi,I met a problem in my first step during using qiime2 to analyse my own data :rofl: I import my data with the command below:

qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path learn
--input-format CasavaOneEightSingleLanePerSampleDirFmt
--output-path demux-paired-end.qza

and i got a qiime tools import: command not founderror,and here are my screenshot

please help me with this,thank you very much

What happens when you type which qiime once you’ve loaded the qiime2 2020.6 environment?

Hi Devon, displayed /home/mzl/miniconda3/envs/qiime2-2020.6/bin/qiime on the terminal when i typed which qiime after activate qiime2-2020.6 environment.

Thanks. Also wondering what happens when you type:
qiime --help

do you get a prompt that prints out the help menu?

yes i got

Nice. Okay, next try out the following:

qiime tools --help
qiime tools import --help

If you get a help menu to print out for both of those, then the program you’re trying to call isn’t your issue.

My recommendation is to try running the entire code as a single line at first, rather than breaking it up with the \ symbol like you mentioned in the screenshot. Using exactly the text you printed in your initial question should work like this:

qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path learn --input-format CasavaOneEightSingleLanePerSampleDirFmt --output-path demux-paired-end.qza

One minor recommendation - if that doesn’t work, try specifying the full path to wherever your learn directory is (what you specified in --input-path).

Yes i got help menu after i tried

then i run the entire import code in a single line and wrote my full path to learn where my data is as you said, unfortunately,i got a new error as diaplayed in the screenshot below :rofl:

i don't know is there any problem with my filename,and my filename looks like:
d85a93c44810366a114dc1f907f92f5
this is the original file i got from sequencing company

Two thoughts on this:

  1. Make sure that the only thing in that learn directory are just your sequence files - only the fq.gz files. Move the sample-metadata.xlsx file out of that directory (don’t create a subdirectory for it, move it back up at least one parent directory level).

Once you are sure that the only thing in learn are your sequence files, try again.

  1. If that fails, maybe try renaming the sequence files within learn so that they don’t start with a number. Not sure if that’s a problem with the qiime tools import function or not. You could just amend a prefix to them using a GNU or Perl rename command, for example.

Hi Devon,
I figured my data-importing problem out , finally! it seems Qiime2 permit a file with filename looks like: sampleID_barcodeID_lane ID_R[12]_set id.fastq.gz for casava1.8 paired-end sequences only,and the suffix should be .fastq.gz instead of .fq.gz like mine,they are theoretically equal,though.
And I want to thank you for your patient guidance to me,your kind help is very inspiring for me as a bioinformatic beginner.

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.